1

I don't know if this is a hardware or software problem, but with my new Dell XPS 13, I find that the caps-lock sticks in the on position and I can't turn it off. Is there a way to prevent caps-lock from ever coming on again? I have the following settings in gnome-tweaks:

Caps Lock Behavior:Disabled
Ctrl position: Caps-lock as control

But neither of these settings prevents caps-lock from being stuck in the on position and forcing default caps-lock behavior.

0

Your hardware could be issue and not the software. I had a similar problem but couldn't turn caps on or off when I needed.

So I swapped the Caps Lock/Esc keys around. Now I can use my Caps Lock as normal, I didn't use my Esc often. This is in the same settings you looked at.

  • 1
    Maybe you could specify how you swapped the keys. – Marc Vanhoomissen Jun 26 at 16:49
0

I had this problem constantly occurring on my XPS-15, Ubuntu 18.04 LTS, and couldn't find answers. Until a moment ago where I just accidentally discovered that * NEWS FLASH * You must have accidentally pressed Shift-CapsLock

Pressing Shift+CapsLock will make CapsLock stick, and following pressings on CapsLock alone will not toggle it back. Only by repressing Shift+CapsLock again CapsLock will be toggled off again into its usual behavioral state.

  • That doesn't happen on my 2018 XPS 13 running Kubuntu 18.04 LTS with HWE. – B.Tanner Aug 17 at 10:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.