10

I recently tried setting up a dual boot of Ubuntu 18.04 LTS with windows 10 already installed on my Asus VivoBook Pro N580GD.

I have tried reinstalling multiple times but every time I get a bunch of Errors:

[  0.055631] ACPI Error: [_SB_.PCIO.RPO5.PXSX] Namespace lookup failure, AE_NOT_FOUND (20170831/dswload2-191)
[  0.055639] ACPI Exception: AE_NOT_FOUND, During name lookup/catalog (20170831/psobject-252)
[  0.055614] ACPI Error: Method parse/execution failed \_SB_.PCIO.RP04.PXSX, AE_NOT_FOUND (20170831/psparse-550)
[  0.055957] ACPI Error: [_SB_.PCIO.RPO9.PXSX] Namespace lookup failure, AE_NOT_FOUND (20170831/dswload2-191)
[  0.055963] ACPI Exception: AE_NOT_FOUND, During name lookup/catalog (20170831/psobject-252)
[  0.922265] Couidn't get size: 0x800000000000000e
[  0.92228] MODSIGN: COuldn't get UEFI db list

tpm tpm0: A TPM error (378) occured get tpm pcr allocation

genirq: Setting trigger mode 1 for irq 131 failed (intel_gpio_irq_type+0x0/0x140)

As suggested on a few websites I tried modifying the boot parameters by putting an acpi=off near the end and then I get the following errors:

Couldn't get size: 0x800000000000000e
MODSIGN: Couldn't get UEFI db list
Gave up waiting for root file system device. Common problems:
- Boot args (cat /proc/cmdline)
    - Check rootdelay = (did the system wait long enough?)
- Missing modules (cat /proc/modules; ls /dev)
ALert! UUID=831a57-400f-4926-97eb-c55a61696e3d does not exist. Dropping to a shell!

Also, when I try running a live Ubuntu USB I can't shut down the computer without pressing the power button.

I am able to boot into the recovery mode from Grub.

Please tell me if you need any information to help me resolve the issue. I don't have much experience with Linux, so I am mostly unable to understand what's happening.

  • Your BIOS has an ACPI table which does not work well with Linux. Try to see if there's any updated BIOS or give up. – Alvin Liang Nov 18 '18 at 19:40
  • I checked and there is no update for my bios available currently. – Parth Sindhu Nov 19 '18 at 16:50
  • I did ramsudharsan solution here and it worked: askubuntu.com/questions/137655/… – emre can Nov 8 '19 at 19:12
6

To Help ALL,

First an explanation of why ACPI errors occur in Linux, and why it can USUALLY be ignored

Second, if hundreds of errors happen on boot like my Hp OmenX Bleeding Edge Laptop, I will show you a trick for Grub (the boot loader) to ignore them, and boot normally

Third, I am posting this as I just upgraded my kernel, and all my "Errors: Quote: ACPI:3400 Unsupported Event" have disappeared, and I will show you how to upgrade your kernel.

ACPI Errors - Microsoft's Fault!!

  • It's supposed to be a standard that any operating system can properly implement. However, in typical Microsoft fashion, MS operating systems do not follow or properly implement the ACPI standard. Instead, MS gives motherboard manufacturers their own improperly implemented ACPI code for inclusion in the motherboard BIOS/UEFI. The code runs fine with MS windows but all for other operating systems like linux there can be problems.

    Because of MS's market dominance, the faulty ACPI implementation from MS has become the de facto industry standard. As a result, Linux and other non-MS operating systems have to reverse engineer the faulty ACPI implementation from MS. That's why you can see problems in Linux with ACPI related functionality like suspend to RAM, hibernate, etc.

  • Apparently, the ACPI related code in certain newer Linux kernels has a problem with the typical BIOS/UEFI ACPI implementation on certain motherboards which is why we're getting those error messages. Even though I get those error messages at the beginning of the boot process, I've had no problems with suspend/resume or any other ACPI related issues.

  • I have seen advice to not run in BIOS legacy mode by disabling UEFI but to run in UEFI mode instead with secure boot disabled. I haven't bothered with it myself since I have several operating systems already installed with BIOS legacy mode and I would have to reinstall everything if I wanted to switch to UEFI mode. (UEFI Mode is working GREAT for my install)

Hp / ACPI Errors

ACPI - Advanced Configuration & Power Interface

To avoid seeing ERROR "acpi int3400 unsupported event" ERRORS...

In the file /etc/default/grub

Add to the line GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" the parameters acpi=off or noacpi acpi=strict

So that after your edit it looks, for example, like this

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=strict"

For me, acpi=strict is working best. You can also try acpi=force, and pnpacpi=off worked For another HP Spector user.

To edit the file you need to open it with root permission, for example by running

sudo -H gedit /etc/default/grub

After editing, update the configuration by running

sudo update-grub

and regenerate the initrd:

sudo update-initramfs -u

and then restart to see the effect

The latest kernel 4.19.5 has ELIMINATED ALL my problematic acpi:3400 errors

Install UKUU:

UKUU - Ubuntu Kernel Update Utility: Manage and Install Newest Bleeding Edge Kernels

sudo add-apt-repository ppa:teejee2008/ppa
sudo apt update && sudo apt install ukuu

and after run UKUU and it will offer to install or uninstall any and of course the newest (stable or not so stable) KERNEL.

IT ALWAYS LEAVES your last working kernel as a backup should the new one not work as well as you would like.

| improve this answer | |
2

If anyone is still struggling with this, the issue was with my graphics card driver(Nouveau). I disabled it using modprobe and the whole thing started working.

On the grub screen, press e and in the line with 'Linux' add the following at the end:

modprobe.blacklist=nouveau 
| improve this answer | |
0

I had to comment few recently; added sambashare and davfs mount paths from /etc/fstab file to boot without errors, I can mount these again once Ubuntu boots.

BTW, I am running Ubuntu 18.04. I still get ACPI errors, but are not blocking the bootup anymore.

| improve this answer | |
0

I had a few weeks of irritation with this problem, and wanted to share some new insights, and to add a helpful point (if you are stuck with not booting properly or black screen of death).

If not booting properly, acpi=strict can be added at boot time, and it is not always an obvious fix.

  1. Just (when GRUB opens) select Advanced Options

  2. If you have 2 or more kernels, select the older one that was working

  3. If it's a new install or there is only one kernel, select the current version (Ubuntu ALWAYS leaves at least one older working kernel in grub when upgrading)

If all above fails here is the more tricky option.

  1. As mentioned above, at boot time, select the kernel in the Advanced Options

  2. Press E

  3. Now it will give you a page of garbled code but worry not, just find GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

  4. Add acpi=strict, like this: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=strict"

  5. Look at the bottom of this page and find the option to save and/or boot with the changes.

This can be really useful.

Good Luck, Any More Questions feel free to ask! As Always,

Trying to help, Mark

| improve this answer | |
  • Unfortunately, none of them worked for me. When I chose previous kernel result is same, initramfs command appears boot does not complete. If I type acpi=strict manually to boot arguments (there is nothing like GRUB_.. variable btw for kubuntu version), whatever I typed them just next to quiet splash commands, it didn't work either. – emre can Nov 8 '19 at 19:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.