4

I recently tried setting up a dual boot of Ubuntu 18.04 LTS with windows 10 already installed on my Asus VivoBook Pro N580GD.

I have tried reinstalling multiple times but every time I get a bunch of Errors:

 
[  0.055631] ACPI Error: [SB.PCIO.RPO5.PXSX] Namespace lookup failure, AE_NOT_FOUND (20170831/dswload2-191)
[  0.055639] ACPI Exception: AE_NOT_FOUND, During name lookup/catalog (20170831/psobject-252)
[  0.055614] ACPI Error: Method parse/execution failed _SB_.PCIO.RP04.PXSX, AE_NOT_FOUND (20170831/psparse-550)
[  0.055957] ACPI Error: [SB.PCIO.RPO9.PXSX] Namespace lookup failure, AE_NOT_FOUND (20170831/dswload2-191)
[  0.055963] ACPI Exception: AE_NOT_FOUND, During name lookup/catalog (20170831/psobject-252)
[  0.922265] Couidn't get size: 0x800000000000000e
[  0.92228] MODSIGN: COuldn't get UEFI db list

tpm tpm0: A TPM error (378) occured get tpm pcr allocation

genirq: Setting trigger mode 1 for irq 131 failed (intel_gpio_irq_type+0x0/0x140)

As suggested on a few websites I tried modifying the boot parameters by putting an acpi=off near the end and then I get the following errors:

Couldn't get size: 0x800000000000000e
MODSIGN: Couldn't get UEFI db list
Gave up waiting for root file system device. Common problems:
- Boot args (cat /proc/cmdline)
    - Check rootdelay = (did the system wait long enough?)
- Missing modules (cat /proc/modules; ls /dev)
ALert! UUID=831a57-400f-4926-97eb-c55a61696e3d does not exist. Dropping to a shell!

Also, when I try running a live Ubuntu USB I can't shut down the computer without pressing the power button.

I am able to boot into the recovery mode from Grub.

Please tell me if you need any information to help me resolve the issue. I don't have much experience with Linux, so I am mostly unable to understand what's happening.

Thanks for trying to help

  • Your BIOS has an ACPI table which does not work well with Linux. Try to see if there's any updated BIOS or give up. – Alvin Liang Nov 18 '18 at 19:40
  • I checked and there is no update for my bios available currently. – Parth Sindhu Nov 19 '18 at 16:50
3

To Help ALL,

First an explanation of why ACPI errors occur in Linux, and why it can USUALLY be ignored

Second, if hundreds of errors happen on boot like my Hp OmenX Bleeding Edge Laptop, I will show you a trick for Grub (the boot loader) to ignore them, and boot normally

Third, I am posting this as I just upgraded my Kernel, and all my "Errors: Quote: ACPI:3400 Unsupported Event" have disappeared, and I will show you how to upgrade your Kernel.

#

First, ACPI Errors - Microsoft's Fault!! ‣ https://en.wikipedia.org/wiki/Advanc...ower_Interface ∘ It's suppose to be a standard that any operating system can properly implement. However, in typical Microsoft fashion, MS operating systems do not follow or properly implement the ACPI standard. Instead, MS gives motherboard manufacturers their own improperly implemented ACPI code for inclusion in the motherboard BIOS/UEFI. The code runs fine with MS windows but all for other operating systems like linux there can be problems. Because of MS's market dominance, the faulty ACPI implementation from MS has become the de facto industry standard. As a result, linux and other non-MS operating systems have to reverse engineer the faulty ACPI implementation from MS. That's why you can see problems in linux with ACPI related functionality like suspend to ram, hibernate, etc.

∘ Apparently, the ACPI related code in certain newer linux kernels has a problem with the typical BIOS/UEFI ACPI implementation on certain motherboards which is why we're getting those error messages. Even though I get those error messages at the beginning of the boot process, I've had no problems with suspend/resume or any other ACPI related issues. Here's another guy with the same problem so you are not alone: ‣ https://www.reddit.com/r/linux/comme..._installation/ ∘ The advice there was to not run in BIOS legacy mode by disabling UEFI but to run in UEFI mode instead with secure boot disabled. I haven't bothered with it myself since I have several operating systems already installed with BIOS legacy mode and I would have to reinstall everything if I wanted to switch to UEFI mode. (UEFI Mode is working GREAT for my install)

#

2nd

Hp / acpi Errors ∘ ACPI - Advanced Configuration & Power Interface • ERROR "acpi int3400 unsupported event" ERRORS ..... ‣ add to grub's ... Quote: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" ... ‣ "acpi=off" or "noacpi" "acpi=strict"

∘ Quote:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=strict"

. ‣ "acpi=strict" WORKING BEST AS OF 09/15/18 ∘ or " acpi=force "

‣ "pnpacpi=off" Worked For another HP Spector and Another posted it AWESOME

To Edit Grub Code:

sudo gedit /etc/default/grub

After Update Grub with • Code:

sudo update-grub

and Update your kernel with • Code:

sudo update-initramfs -u

and of course Restart to take effect

3rd The latest kernel 4.19.5 has ELIMINATED ALL my problematic acpi:3400 errors Install UKUU

UKUU - Ubuntu Kernel Update Utility • Manage and Install Newest Bleeding Edge Kernels

• Code:

sudo add-apt-repository ppa:teejee2008/ppa

• Code:

sudo apt update && sudo apt install ukuu

and after run UKUU and it will offer to Install or Uninstall any and of course the newest (stable or not so stable KERNEL.

IT ALWAYS LEAVES your last working kernel in grub as a backup should it not work as well as you would like

Good Luck, Always trying to help, Mark

1

If anyone is still struggling with this, the issue was with my graphics card driver(Nouveau). I disabled it using modprobe and the whole thing started working.

On the grub screen, press e and in the line with 'Linux' add the following at the end:

modprobe.blacklist=nouveau 
0

I had a few weeks of irritation with this problem? And wanted to share the new insights!

And to add a OBVIOUSLY MISSED helpful point (if you are stuck with not booting properly or black screen of death).

If not booting, the same Quote: acpi=strict can be added at boot time, and it is NOT obvious at all to newbies!

Just (when GRUB opens) select "Advanced Options" Now IF you have 2 or more kernels use an (select) the older one that WAS working, ... EASY PEASY. Now, IF it a new install or there is only one kernel (Ubuntu ALWAYS leaves at least one [SECOND] OLDER working kernel in grub - SMART!)

SO if all above fails here is the more tricky option ... ... add the

acpi=strict

as mentioned above ... AT BOOT TIME! ... ... highlight (select) the kernel in the advanced option and

PRESS Quote:

E

Now it will give you a page of garbled code but worry not, Just find Quote:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

and add acpi=strict, to look like Quote:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=strrict"

and look at the bottom of this page and find the option to save and/or boot with the changes.

This CAN BE REALLY USEFUL!

Good Luck, Any More Questions feel free to ask! As Always,

Trying to help, Mark

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.