When I use TeXworks there is no automatic spell checking. If I go Edit -> Spelling, the only option I have is none

How can I enable spell checking?

Thanks for your help

4 Answers 4


In case you already have LibreOffice installed, the en_US.aff and en_US.dic files are already on your system in the /usr/share/hunspell folder. In this case, just symlink these two files into /usr/share/myspell/dicts and you are done:

sudo ln -s /usr/share/hunspell/en_US.dic /usr/share/myspell/dicts/
sudo ln -s /usr/share/hunspell/en_US.aff /usr/share/myspell/dicts/

You can do so for all dictionaries you find in /usr/share/hunspell.

Restart Texworks afterwards.

You can see Texworks > Edit > Spelling > Unites-States now. Click it.

Also change Texworks > Edit > Preferences > Editor > spell-check-language > English-United-States.

You are done after restarting.

  • 1
    It's 16.04 and I still have to manually create these links...
    – not-a-user
    Commented Aug 24, 2016 at 11:59
  • I again came across this issue in Ubuntu 18.04. My TeXworks did offer the de-lu instead of the de-de language for no good reason. When I uninstalled the myspell-de-de package and marked the hunspell-de-de package as installed manually (to avoid it gets uninstalled together with the myspell-de-de package), the issue was solved. So it seems nowadays, better get rid of the myspell-**packages. The package description in Ubuntu 18.04 says it can be safely removed. Commented Sep 5, 2018 at 15:42

There is a section of the TeXWorks manual in which there is the reference to a guide on how to use dictionaries.

The link it refers to is this, so you should place your personal dictionaries in the folder /usr/share/myspell/dicts.

One easy way to add them is to install them. I suppose that if you use LibreOffice then they are installed by default. If not, you can simply install the packages named myspell-XX, where XX stands for your language.

You can easily find them with apt-get and auto-completion or via Synaptic.

  • Thanks, I had actually seen that but I already had a bunch of dictionaries in that directory. However apt-get'ing the same dictionary I normally use fixed the problem magically!
    – Anake
    Commented Mar 2, 2012 at 15:20
  • I tried this. But still it doesn't show up in my spelling sections.
    – MycrofD
    Commented May 2, 2016 at 10:15
  • You can please share this answer in tex.SE (for others' benefits) here : tex.stackexchange.com/q/235313/52071
    – MycrofD
    Commented May 2, 2016 at 10:18
  • @MycrofD not sure, that question is for Windows :)
    – dadexix86
    Commented May 2, 2016 at 10:20
  • Oh I see. My bad. And yes my problem was solved only after I installed as you said.. and then I had to symlink the respective files..as solved below by @SPSJNU2006-2014
    – MycrofD
    Commented May 2, 2016 at 10:36

You might have hunspell dictionaries in the language you need already installed. Look for them in the folder /usr/share/hunspell and maybe you don't have to install a thing.


I just installed ubuntu 18.04 on an old toshiba laptop. The config file of TeXworks looks for its dictionaries in /usr/share/hunspell. And it is not easy (if possible at all) to change this behaviour. But one can copy (or move) the dictionaries that have been installed. Or download them from Open Office; they will be with oxt extension but these are zip files and making the extension from oxt to zip does the job, then unzip these. You need the *.aff and *.dic files only (plus the rules for hyphenation if any). Then you need root access to copy or move these to /usr/share/hunspell. If you have it, just open terminal in the folder where the files are: sudo cp /usr/share/hunspell/filename And that is it. Another advantage: If you want to switch to TeXstudio then from its config menu you can select the folder where the dictionaries are. So you can select the same.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .