0

Editing kernel parameters and removing 'quiet' and 'splash' doesn't bring loading text - I continue seeing black screen with no text. Pressing ESC doesn't magically show anything either. The first thing which is displayed so far - SDDM login screen (Kubuntu here).

/etc/default/grub contents:

$ cat /etc/default/grub
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"


I'm not sure which version of GRUB should I report, so instead I'll just list all the GRUB packages that are installed:
  • grub-common 2.02-2ubuntu8.7
  • grub-efi-amd64 2.02-2ubuntu8.7
  • grub-efi-amd64-bin 2.02-2ubuntu8.7
  • grub-efi-amd64-signed 1.93.8+2.02-2ubuntu8.7
  • grub2-common 2.02-2ubuntu8.7

Also if it matters:

  • Video card: nVidia GeForce 980 GTX Ti
  • Video driver: proprietary version 410
  • Kernel: 4.15.0-39
3
  • 2
    It might help seeing /etc/default/grub contents. Also mention if you ran sudo update-grub after changing the file. Nov 17, 2018 at 16:56
  • @WinEunuuchs2Unix sorry, I should have shared it (updated). I didn't change this file yet - I only edited kernel parameters online when booting.
    – Onkeltem
    Nov 18, 2018 at 9:17
  • You could try: GRUB_CMDLINE_LINUX_DEFAULT="nosplash" which is subtly different but it might not help. It's could be an issue with video driver on boot and you might need to use: GRUB_GFXMODE=640x480 or some derivative of it. Nov 18, 2018 at 15:44

2 Answers 2

1

In addition to removing quiet splash from GRUB_CMDLINE_LINUX_DEFAULT
Uncomment (remove #) from the line: #GRUB_TERMINAL=console.

sudo update-grub

and reboot.

0

Make sure you don't have plymouth-theme-ubuntu-text package installed. Check if you have it using dpkg -s plymouth-theme-ubuntu-text|grep Status. If exists remove it by apt-get remove plymouth-theme-ubuntu-text.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.