0

I used Unetbootin to make a USB bootable disk with Cosmic Cuttlefish pre-release and post. It is the same USB stick I've used for at least 4 previous Linux systems, Ubuntu and Fedora. (On this same laptop.) Immediately on boot it says it can't find MMX64.efi. Looking in the boot directories there is no such efi file. Doing research I find I have to modify the EFI or turn off EFI in the BIOS. I have an HP Pavilion laptop with AMD A8 Elite Quad-core. Turning off the bios Legacy just makes the boot fail even before I get the Can't find error message. Trying to use efibootmgr it says: "EFI variables are not supported on this system." Doing more research efibootmgr is for Intel.

Any suggestions would be helpful. Trying to upgrade to my namesake, FeiWuzei 飞乌贼 is flying cuttlefish in Chinese.

  • What tool did you use to make installer? Have seen similar issue with Rufus installer tool. Some work arounds: askubuntu.com/questions/1085550/… My latest update of grub has in /EFI/Boot/ a file mmx64.efi. That is a key manager related to UEFI Secure boot keys which we normally do not directly mess with. – oldfred Nov 17 '18 at 3:35
  • "I used Unetbootin to make a USB bootable disk with Cosmic Cuttlefish" I was thinking about trying a different one, but I've used Unetbootin before as well as YUMI, windows app, under Wine. – Feiwuzei Nov 17 '18 at 7:28
  • If you do not need BIOS boot. UEFI only USB key, just extract ISO ( 7 zip or similar) to FAT32 formatted flash drive partition & set boot flag. askubuntu.com/questions/395879/… – oldfred Nov 17 '18 at 13:14
  • Yep, Just rename the boot file. Make it happy. "Never does what I want only what I tell it." – Feiwuzei Nov 18 '18 at 1:24
0

I had the same problem (on my Acer Switch Alpha12), these are the options I chose in the BIOS:

Boot:

  • System boot mode: UEFI
  • Secure Boot: Enabled

Security:

  • I changed the bootloader file to grubx64.efi

This is what the path looked like for me:

BIOS > Security > Select an UEFI file as trusted for executing HDD0 > EFI > ubuntu > grubx64.efi

Then a prompt came up saying

Do you wish to add this file to allowable database?

I selected yes.

Exit-Save changes.

I hope that solves your problem

0

Just rename the .efi to what it is lookin for,MMX64.efi, and then everybody is happy. Oh! and now it will boot. To many parts to track everyone. (got it from another site.)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.