3

I started having problems booting after I tried to use prime-select for the first time to switch between my laptop's Nvidia GTX 960M and Intel graphics, using the same nvidia-390 driver that had worked fine for months.

The computer would boot to black, then to tty if I put nomodeset in grub, then after reading a zillion Ask Ubuntu pages and reinstalling a lot of packages, I did sudo apt purge *nvidia* and switched to the new nvidia-driver-415. I also added nouveau.modeset=0 to /etc/default/grub.

Now it boots and runs fine, but only if I manually edit grub every time I boot and remove the $vt_handoff parameter that shows up after nouveau.modeset=0. If I don't, it boots to black, and I can't even get a tty. What gives?

Doing some digging, I found an old bug report that suggests that a missing /boot/grub/gfxblacklist.txt file could disable a graphical boot. I don't have that file. I considered installing grub-gfxpayload-lists as suggested by that post, but it looks like it might conflict with more recent grub-related packages and wreck shop. I'm relatively new to linux and hesitant to mess around with the guts of the OS in case I break something I don't understand.

Any ideas? I would greatly appreciate any help.

More details, let me know if I can include anything else: Dell Inspiron 7559, dual boot with Windows 10 (Secure Boot off); Ubuntu 18.04.1 LTS; kernel 4.15.0-39-generic; graphics Nvidia GeForce GTX 960M/PCIe/SSE2; GNOME 3.28.2; /etc/default/grub : link

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.