I have a Dell Inspiron with Ubuntu 12.04 installed. I can use my touchpad fine but I can't scroll with it. When I run windows it uses two finger scrolling but for some reason it won't work on Ubuntu. I went to my mouse and touchpad settings but there is no touchpad tab, only a mouse tab. When I run xinput list I get the following:

Virtual core pointer                        id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ PS/2 Generic Mouse                        id=13   [slave  pointer  (2)]
⎜   ↳ PIXART USB OPTICAL MOUSE                  id=11   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Power Button                              id=8    [slave  keyboard (3)]
    ↳ Sleep Button                              id=9    [slave  keyboard (3)]
    ↳ Laptop_Integrated_Webcam_HD               id=10   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=12   [slave  keyboard (3)]
    ↳ Dell WMI hotkeys                          id=14   [slave  keyboard (3)]

Apparently my touchpad is detected as a PS/2 Generic Mouse. Is there a way to fix this?? I've had this problem with Ubuntu 11.10 and when I upgraded to 12.04 today the problem still exists. The reason this is bugging me is because whenever I type, my pointer goes erratic and often makes me mistype (at least in windows, this happens because I have touchpad driver installed).

  • Same problem here. Have you found a workaround? – Beni Bogosel Jul 14 '12 at 14:34
  • I started having similar problems after I added psmouse.proto=imps to the kernel options to try to cure other anomalies. I removed it, and I have the Touchpad configuration screen and multitouch are back. There might be a clue to your case there. – Apalala Mar 13 '13 at 2:32

Try this:

sudo modprobe -r psmouse
sudo modprobe psmouse proto=imps

If it works add both the lines to:


But add them without the leading sudo. So the lines you'll add to /etc/rc.local will look like:

modprobe -r psmouse
modprobe psmouse proto=imps

If /etc/rc.local ends with something like exit 0, make sure to add those lines before that exit line.


I had exact same problem on my Inspiron N5110 running Ubuntu 12.04 but was able to fix it using patch and instructions provided in these two links.



Touchpad is now recognised as AlpsPS/2 ALPS DualPoint TouchPad and Touchpad tab is enabled in System Settings. Unfortunately, scrolling is still not an option... :-(

At least touchpad is disabled while typing, which was the biggest problem for me resulting in cryptic writings! :-) Also Fn+F3 is working now (aka, touchpad toggle).

  • Latest update on bug 606238. Multitouch has been enabled for Alps touchpad which works on my Dell Inspiron N5110, but should work for other laptops. You have to install this DLKM. – JKMirko Sep 28 '12 at 22:16

On my Dell Vostro 1520 I had the same issue, but I resolved it by doing the following Eliah's answer, with one small modification to the code:

sudo modprobe -r psmouse
sudo modprobe psmouse

And added the following before the exit call to the file he indicated:

modprobe -r psmouse
modprobe psmouse

Basically, it seems that the proto=imps option is the cause here, and should not be used with an Alps device ...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.