1

I am trying to connect to a shared drive on a remote Windows machine. When I type the IP address of the windows machine into the "Connect to Server" field, the "Connect" button is grayed out and I just see the busy wheel.

This answer implies that I need to run sudo apt install gvfs-backendsbut doing that just leads to the following problems:

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 gvfs-backends : Depends: gvfs (= 1.36.1-0ubuntu1) but 1.36.1-0ubuntu1.1 is to be installed
                 Depends: gvfs-daemons (= 1.36.1-0ubuntu1)
                 Depends: gvfs-libs (= 1.36.1-0ubuntu1) but 1.36.1-0ubuntu1.1 is to be installed
                 Depends: gvfs-common (= 1.36.1-0ubuntu1) but 1.36.1-0ubuntu1.1 is to be installed
E: Unable to correct problems, you have held broken packages.

I am on Ubuntu 18.04. Is this broken or something? How can I get the remote connection to work?

Update: I have run sudo apt update and nothing changes.

The output of apt-cache policy gvfs gvfs-backends is:

gvfs:
  Installed: 1.36.1-0ubuntu1.1
  Candidate: 1.36.1-0ubuntu1.1
  Version table:
 *** 1.36.1-0ubuntu1.1 100
        100 /var/lib/dpkg/status
     1.36.1-0ubuntu1 500
        500 http://us.archive.ubuntu.com/ubuntu bionic/main amd64 Packages
gvfs-backends:
  Installed: (none)
  Candidate: 1.36.1-0ubuntu1
  Version table:
     1.36.1-0ubuntu1 500
        500 http://us.archive.ubuntu.com/ubuntu bionic/main amd64 Packages

Results of sudo apt-cache policy gvfs gvfs-daemons gvfs-libs gvfs-common:

gvfs:
  Installed: 1.36.1-0ubuntu1.1
  Candidate: 1.36.1-0ubuntu1.1
  Version table:
 *** 1.36.1-0ubuntu1.1 100
        100 /var/lib/dpkg/status
     1.36.1-0ubuntu1 500
        500 http://archive.ubuntu.com/ubuntu bionic/main amd64 Packages
gvfs-daemons:
  Installed: 1.36.1-0ubuntu1.1
  Candidate: 1.36.1-0ubuntu1.1
  Version table:
 *** 1.36.1-0ubuntu1.1 100
        100 /var/lib/dpkg/status
     1.36.1-0ubuntu1 500
        500 http://archive.ubuntu.com/ubuntu bionic/main amd64 Packages
gvfs-libs:
  Installed: 1.36.1-0ubuntu1.1
  Candidate: 1.36.1-0ubuntu1.1
  Version table:
 *** 1.36.1-0ubuntu1.1 100
        100 /var/lib/dpkg/status
     1.36.1-0ubuntu1 500
        500 http://archive.ubuntu.com/ubuntu bionic/main amd64 Packages
gvfs-common:
  Installed: 1.36.1-0ubuntu1.1
  Candidate: 1.36.1-0ubuntu1.1
  Version table:
 *** 1.36.1-0ubuntu1.1 100
        100 /var/lib/dpkg/status
     1.36.1-0ubuntu1 500
        500 http://archive.ubuntu.com/ubuntu bionic/main amd64 Packages
        500 http://archive.ubuntu.com/ubuntu bionic/main i386 Packages
  • Did you forget to run sudo apt update? Please add output of apt-cache policy gvfs gvfs-backends to the question. – N0rbert Nov 16 '18 at 10:17
  • @N0rbert I ran sudo apt update. My question is updated. – Startec Nov 16 '18 at 10:37
  • 1
    Then try to change mirror to Main server (as on these screenshots) and retry. – N0rbert Nov 16 '18 at 10:41
  • @N0rbert I switched to main, ran sudo apt update and sudo apt-get dist-upgrade and get the same error :( – Startec Nov 16 '18 at 10:46
  • Please update your question with output of apt-cache policy gvfs gvfs-daemons gvfs-libs gvfs-common. – N0rbert Nov 16 '18 at 11:10
1

During chat session we have discovered, that bionic-updates repository was disabled.

So we have enabled it from Software & UpdatesUpdates tab (software-properties-gtk):

enabling bionic-updates

and then confirm reloading of package lists.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.