0

I have followed below steps to install Ruby1.9.1 on ubuntu 18.04 but it is showing latest ubuntu version after installation:

Steps:

sudo apt-get install ruby1.9.1-full
sudo apt-get install rubygems1.9.1
sudo apt-get install ruby1.9.1-dev
sudo update-alternatives --install /usr/bin/ruby ruby /usr/bin/ruby1.9.1 1

Response:

Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package ruby1.9.1-full
E: Couldn't find any package by glob 'ruby1.9.1-full'
E: Couldn't find any package by regex 'ruby1.9.1-full'
Ruby apt-get installation failed, make sure that apt is working correctly and try again
./install_opentest.sh: line 135: break: only meaningful in a `for', `while', or `until' loop
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package rubygems1.9.1
E: Couldn't find any package by glob 'rubygems1.9.1'
E: Couldn't find any package by regex 'rubygems1.9.1'
rubygems apt-get installation failed, make sure that apt is working correctly and try again
./install_opentest.sh: line 135: break: only meaningful in a `for', `while', or `until' loop
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package ruby1.9.1-dev
E: Couldn't find any package by glob 'ruby1.9.1-dev'
E: Couldn't find any package by regex 'ruby1.9.1-dev'

Is it possible to install ruby1.9.1 on Ubuntu 18.04?

0

According to search on http://packages.ubuntu.com Ruby 1.9.1 is available only for Ubuntu 14.04 LTS.

According to official Ruby Maintenance Branches page 1.9.3 (as also 2.0.0, 2.1, 2.2) is EOL.

Consider to install supported version of Ruby 2.5.1 for your Ubuntu 18.04 LTS:

sudo apt install ruby2.5 ruby2.5-dev

If you really need to install 1.9.1 - then compile it manually. But make sure that you want to use end-of-life and insecure version.

  • Thanks! Yes, I have dependency on ruby1.9.1 or ruby1.9.3. Is it possible for you to share steps to install ruby1.9.1-full, rubygems1.9.1, ruby1.9.1-dev, please? ruby1.9.3 will also work. – Swapnil Nov 16 '18 at 11:37
  • Any leads on how to configure ruby 1.9.1 or 1.9.3 on Ubuntu 18.04? – Swapnil Nov 22 '18 at 16:07
  • I do not know. Use search here or on internet. – N0rbert Nov 22 '18 at 16:10

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.