I use Ubuntu 12.04 on a two screen setup. Multiscreen on 12.04 has generally become much better, but there is one thing that really gets on my nerves: there's a mouse magnet of sorts on the middle edge (between the two screens). It's undoubtedly there to make it easier to interact with the launcher on the right screen. But I have enough trust in my mousing skills, the magnet is more annoying than helpful in my case. Can I disable it somehow?

  • 2
    I don't know if it's there to make it easier to interact with the launcher or if instead it is to make it easier to snap windows to fill the right or left half of the screen. – Gus Sep 14 '12 at 23:06
  • 11
    If there are so many upvotes for this question, the sticky edges should by default be False. – don.joey Aug 14 '14 at 13:30

11 Answers 11

up vote 475 down vote accepted

There is a setting for it in Displays:

enter image description here

You may still get the behaviour if you have a launcher on the right monitor, so use the "Launcher Placement" option to select having your launcher on only the left screen. The stickyness between the screens is required for it to be easy to retrieve the launcher there.

You might need to log out and back in (or restart) for the changes to take effect.

  • 1
    I had a similar effect, because the monitors had a space between them (in the dialog above). After dragging them together, the cursor appeared right away afer leaving the other screen. – iGEL Apr 30 '13 at 21:47
  • 14
    OMG! I can't believe I didn't see this. My life became so much easier. – Eduard Luca Jul 3 '13 at 11:24
  • 1
    Works in 13.04 too – metasequoia Jul 26 '13 at 20:15
  • 2
    FWIW, I didn't have to restart in 13.10. It took effect as soon as I hit 'Apply'. – Geobits Dec 11 '13 at 0:56
  • 2
    For 12.04 with the right monitor Launcher disabled, this did not work. The mouse moves easily from the left monitor to the right, but faces a big overcome_pressure value moving from right to left. I recommend Schinstad's answer instead. – H2ONaCl Jul 5 '14 at 5:11

The "hang" is a feature to make it possible to use the launcher in multi-monitor setups when it's set to auto-hide. It can be configured using gconf-editor. The relevant keys are

/apps/compiz-1/plugins/unityshell/screen0/options/stop_velocity, and

/apps/compiz-1/plugins/unityshell/screen0/options/overcome_pressure

Recommended settings to minimize the effect are:

  • overcome_pressure=1
  • stop_velocity=20

These settings do not completely stop the mouse from sticking, but makes it less likely it will do so. You can reduce stop_velocity further if you want.

Possibly also /apps/compiz-1/plugins/unityshell/screen0/options/reveal_pressure. The latter can be configured more easily in System Settings -> Appearance -> Behavior.

  • Thank you. I'm glad you found it useful. There is often more than one way to answer a question and I think the accepted answer is easier and more accessible to more people, so I'm very comfortable being in the second place :) – Jo-Erlend Schinstad Jun 20 '14 at 23:04

You can also modify the settings inside of CCSM if you prefer a GUI option. Its under CSSM > Unity > Experimental

There are options for Launcher Edge Stop Overcome Pressure and Edge stop Velocity which you can modify.

  • 2
    install ccsm with "sudo apt-get install compizconfig-settings-manager". Run with "ccsm". Search/filter for "ubuntu unity plugin", click on it. "Experimental" tab. "Edge stop velociy" of 15 - 20 worked for me. – Jeffrey Martinez Jan 6 '14 at 7:13
  • Or from GUI run Ubuntu Software Center, search for compizconfig-settings-manager, and install. Then click on Ubuntu Search, search for compizconfig-settings-manager and run it. – robocat Oct 19 '14 at 21:44
  • This worked relatively well for me. Do note that this is now placed under "Launcher" (not experimental anymore). Setting "Edge stop velocity" to 1, "Pressure decay rate" to 1 and "Duration of stickey edge release after Break" to 0 got rid of it (almost) completely. Otherwise you can set the launcher to only show on the left, and then it really doesn't show up anymore. – Bono May 18 '17 at 6:41

I personally thought it could be a wrong design in an extended desktop where in the middle of the desktop, a launcher is present. Yet, notice that the launcher has new settings :

enter image description here

The reveal sensitivity allows you to adjust how much the launcher is sensitive to your mouse crossing. The higher, the more you have to push the mouse against the launcher to reveal it. While auto-hide is activated, and about 27 % of reveal sensitivity, you can surf your mouse from the left external monitor to the right one or the opposite, easily without accidently revealing the launcher. Check the poll, if you want to vote for this option.

Thanks to Hanynowsky's answer https://askubuntu.com/a/111316/29209

  • 3
    I think there is an error in your answer: at least in my system, the lower the sensitivity, the more you have to push the mouse, not the other way. – Cmorales May 7 '12 at 13:22

For anyone elses reference. I ended up setting 'Edge Stop Velocity' to 10,
Launcher Edge Stop Overcome Pressure to 10, and Launcher Reveal Pressure to 10.

This seems to give the perfect balance for me. No lag when dragging windows between screen. Launcher is fairly easy to access on both monitors, No mis-reveals when going for the back button in the browser...

  • 1
    How exactly did you get to the place where you could change those settings? – David Cary Feb 28 '14 at 5:10

Also if you want to leave it the way it is I have found that moving the mouse VERY quickly past the middle will let you pass right through it without even the slightest bit of hang time. I still changed it mainly because moving the mouse that fast was a bit annoying. Maybe someone will find it useful though.

  • Even I found having to move the mouse pointer that fast to be annoying. Changing the setting is best. – Nav May 15 '13 at 6:38

There is also the "Launcher Monitors" option in CCSM under "Ubuntu Unity Plugin". Switching this to "Primary Desktop" solved the problem for me in the laptop + external monitor setup.

  • For me too. I am using ubunutu 16.04. – M.C. Dec 19 '16 at 10:52
  • oh thanks! its 2018 and this is still a mess! only your suggestion worked after all these years! – peteroak May 5 at 2:52

in CCSM there is a setting under Experimental tab called Launcher Capture Mouse. if you disable it than the effect will completely disabled

  • This worked for me, no other answer did. – Prof. Falken Oct 31 '12 at 13:16
  • It was un-checked when I opened the Launcher conf tab, but I still have a problem with the mouse pointer sticking to the screen edge. – Tomislav Nakic-Alfirevic Apr 28 '17 at 9:03

The launcher capture mouse option in ccsm and the settings>displays "Sticky edges" options didn't stop the edge capture from right to left for me. The only thing that worked was setting the "Launcher Edge Stop Velocity" to 1 and having , that solved the issue for me. No other modifications required.

I have no interest in Unity launcher menu on my secondary right hand screen, and the hastle this caused in day to day use was an unwelcome pain. I didn't realise the ccsm Unity experimental settings were there so I had to live with it for about 4 months. God that was annoying.

  • 3
    I had the same problem (right-to-left remained sticky). I solved it in Displays by setting Launcher Placement to All Displays, clicking Apply and Keep This Configuration, then setting it back to only the left display. Setting Edge Stop Velocity to 1 meant I couldn't open the Launcher (on left screen) with the mouse, and I still had a (slightly) sticky edge. – drevicko Aug 9 '13 at 0:49
  • @drevicko - you should add this as an answer, that's the only thing that worked for me – geoffrey Mar 24 '14 at 7:43

The problem only happens when you have the launcher placed on "All Displays". I had already changed "Settings > Displays > Sticky edge > OFF", but there was no improvement. So I changed "Settings > Displays > Launcher Placement" to my first monitor only (removing "All Displays"), and the problem disappeared.

  • I am using 14.04, and setting Sticky Edge OFF was enough for me. – Martin Bonner Jul 20 '16 at 7:33

As another option, you can always set the following gconf values under /apps/compiz-1/plugins/unityshell/screen0/options:

  • overcome_presure=1
  • stop_velocity=5

These settings will basically turn off sticky edges, as well as the ability to access the launcher by using the mouse.

You can then use the "Super" (Windows/Apple) key (or Alt+F1) to access the launcher via keyboard ;)

protected by Mitch Oct 9 '14 at 10:56

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.