7

I have a laptop with a USB-C port to which I connected my USB-C earphones (earbuds from Google, not the Bluetooth ones). The device is correctly listed in the audio output channels, but selecting them doesn't affect the audio system, which continues to output from the laptop speakers.

Audio Settings

As you can see from the screenshot above, I selected the device, but when I press "Test Speakers" the audio keeps coming from the Laptop Speakers.

I tried pavucontrol and the USB-C device is not listed there. See screenshot below

Pavucontrol

If I use the command line utility speaker-test, I am able to force the audio through the earphones. Specifically this command works perfectly.

speaker-test -D plughw:earbuds -c 2

Any suggestion on how to route the system audio through the earphones?

System data: - Ubuntu 18.10 - Laptop: Huawei Matebook X Pro - Earphones: Google Earbuds (HW ID 18d1:5033)

4
  • Similar question have you tried the answers from this askubuntu.com/q/447718/622095 – Antony Nov 16 '18 at 4:22
  • Yes, as shared in the first screenshot the device is selected bu the output is still from the laptop speakers. Tried Pavucontrol and Alsamixer as well. The other solution (editing /etc/asound.conf) is not plug & play – Andrea Olivato Nov 16 '18 at 14:27
  • If you reboot while the headphones are plugged in, do they start to work? – Moshe Katz Nov 23 '18 at 8:00
  • Thanks for the suggestion Moshe, I will try and let you know – Andrea Olivato Nov 23 '18 at 11:03
3

Sounds to me like, a channel that is not seen by the user accessable puleaudio controls is muted.

Open a terminal:

cat /proc/asound/cards 
#Take note of what is there.

Run alsamixer:

alsamixer

You will now see a user interface. In this user interface, you can do the following:

Select your correct sound card using F6 and select F5 to see recording controls as well
Move around with left and right arrow keys.
Increase and decrease volume with up and down arrow keys.
Increase and decrease volume for left/right channel individually with "Q", "E", "Z", and "C" keys.
Mute/Unmute with the "M" key. An "MM" means muted, and "OO" means unmuted. Note that a bar can be 100% full but still be muted, so do check for this.
Exit from alsamixer with the Esc key. 
3

I tried the solution from Michael Prokopec, but the audio channel was not muted. I found, however, that the applications trying to play audio were trying to use the "Built-in Audio Analog Stereo" device. USB headphones, or at least the Pixel Earbuds, register themselves as entirely separate audio devices. To get audio to play through the USB-C earbuds, I had to manually change the audio device in pavucontrol.

1
  • Same thing in Debian 10. USB C earphones register as a seperate audio device in volume control. You have to manually select that as the default output device. – Awakened Oct 20 '20 at 17:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.