I have the multi-functional printer/scanner Brother MFC-L2710DN.
But I cannot install its drivers on my computer with Ubuntu 18.04.

The USB-cable is connected.
I could not find drivers for MFC-L2710 in the table from Brother for Ubuntu.
What driver could I take for this device?

  • I wanted to add a link to a description of your printer, but I may accidently have added more than that... – zx485 Nov 15 '18 at 20:21
  • Go to: support.brother.com/g/b/… Update your question if you have any issues following the instructions there. – WinEunuuchs2Unix Nov 16 '18 at 1:26

Thank you very much for your quick answers.
I solved the problem by installing

sudo ./linux-brprinter-installer-2.2.1-1

I went through all possible tutorials several times, but nothing helped but the installation of this Brother support entity.

This solved the problem.

I suspect a possible USB port corruption or lack of support for USB 3.0, because the scanner came to life when I passed it to another USB 2.0 port on my HPG255 laptop.

I will add that Ubuntu was upgraded from an older version on which drivers were already installed with a working scanner (on this port) and a working printer.

| improve this answer | |

This page helped me alot to get printer and scanner to work via network: https://wiki.ubuntuusers.de/Scanner/Brother/

Via USB the scaner ocasionally did not work for me.

The printer works fine via cups alone, but for the scanner the drivers "bscan4" and "bscan-skey" from the brother homepage are required.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.