29

Not sure of the terminology here, but most of my popup dialogs (see screenshot below) are attached to the window title and cannot be moved. If the parent window is moved, the popup moves with it. Is there a way to get rid of this and have all popup dialogs be opened as movable windows?

screenshot with GNOME

Ubuntu 17.10+ with GNOME Shell

screenshot with ginnamon

Ubuntu 11.10 with Cinnamon

  • BTW FYI the correct terminology here would be a "modal dialog". That's also how it is (correctly) called in the GNOME tweak tool, see my answer below. – rugk Nov 30 '17 at 20:47
26

I found a much easier solution. Actually you can configure it with the GNOME Tweaks (previously known as "GNOME Tweak Tool"): "Attached model dialogs" under "Windows" disabled

Just disable "Attached modal dialogs" under "Windows".

| improve this answer | |
  • 2
    This should be the accepted answer at this time. – Nicolás Nov 29 '17 at 18:20
  • This has been bugging me for months in Debian 9... such an easy fix! – pagliuca Apr 8 '18 at 11:17
  • why this is still enabled by default in 20.04 ubuntu? what a genius invented this feature ... – madzohan Aug 3 at 9:59
  • @madzohan: Didn't you hear? Giving users too much flexibility scares them away! So say a lot of today's UX designers, anyhow. I say, when done properly, flexibility makes software better and easier for more users. – Michael Scheper Aug 25 at 20:48
18

Just for those that was unable to solve this, here is what I did to make my dialogs moveable.

I used dconf-editor which can be easily installed by: sudo apt-get install dconf-editor

  1. Open: dconf-editor
  2. Browse to: org -> gnome -> shell -> overrides -> attach-modal-dialogs
  3. Set it to: false

Or everything in one line without installing dconf-editor:

  1. Detach dialog: dconf write /org/gnome/shell/overrides/attach-modal-dialogs false
  2. Attach dialog: dconf write /org/gnome/shell/overrides/attach-modal-dialogs true

Using Ubuntu 12.04 BTW.

| improve this answer | |
  • Thank you for this. Upped. Though, I must admit that this question is hard to find. – Chuck R Oct 27 '12 at 6:05
  • @ChuckR I edited the title to make it more search-friedly. – Rmano Dec 25 '15 at 11:37
9

For GNOME Shell

You can disable it in gnome-shell with a single command in the terminal. Open it with Ctrl + Alt + T shortcut and use the command below:

gsettings set org.gnome.mutter attach-modal-dialogs false

You will get rid of that popup attachment.

On older versions of GNOME Shell was under org.gnome.shell.overrides, probably since this issue.

For Cinnamon

To disable the same on cinnamon, you need this command

gconftool-2 --set --type=bool /desktop/cinnamon/windows/attach_modal_dialogs false

You can use gconf-editor to do the same thing. Install it with sudo apt-get install gconf-editor command.

| improve this answer | |
2

This is by design in Cinnamon, as well as in gnome shell

This feature is for arranging Modal Dialogs within their parent window, and can be disabled gnome shell by the use of gconftool. It can also be disabled in cinnamon.

This feature has also been seen in Mac OSX

| improve this answer | |
  • 3
    So if the dialog hides information in the parent window, you're out of luck? Yet another stupid design decision by Ubuntu UI developers. :( – JesperE Mar 2 '12 at 7:41
  • 2
    There should be a way of detaching the dialog like a Double click or something. – Mashimom Mar 4 '12 at 14:31
  • 1
    @JesperE - This isn't a decision made by the Ubuntu UI developers, but by the GNOME design team (and kept by the Cinnamon design team). In fact, vanilla Ubuntu has the "dialogs attached to windows" behavior turned off by default in 12.04. – Shauna Jul 5 '12 at 12:51
2

The "design decision" is based on how macOS does it. It solves the problems with modal dialogs popping up without seeing to which program they belong to. The dialog should provide enough information to make your choice.

However, at least for gnome-shell you can change this behavior with

gsettings set org.gnome.mutter attach-modal-dialogs false
| improve this answer | |
1

None of the command-lines above worked for me on Gnome 3.30.2. This did:

gsettings set org.gnome.mutter attach-modal-dialogs true

or

gsettings set org.gnome.mutter attach-modal-dialogs false

and, to get the current setting:

gsettings get org.gnome.mutter attach-modal-dialogs
| improve this answer | |
0

On my Ubuntu 12.04 with Cinnamon, I used the gconf-editor method, but the path was org -> cinnamon -> overrides -> attach-modal-dialogs

| improve this answer | |
-1

I found a link with a way to fix this, this method is outdated in newer releases and gsettings should be used instead.

In GNOME 3 the default modal dialog behavior is to attach the window so both the back and front window will be firmly attached together and dragging one of them will move even the other window, like if they became a single window.

enter image description here

This behavior can be changed to restore the old way the modal dialogs were treated in the previous GNOME releases. To detach the modal dialogs from the main window you will just need to execute the following command (in a single line) inside a terminal window:

gconftool-2 --set /desktop/gnome/shell/windows/attach_modal_dialogs false --type bool

To attach the modal dialogs to the parent window you could execute:

gconftool-2 --set /desktop/gnome/shell/windows/attach_modal_dialogs true --type bool

After issuing one of the previous commands you'll need to restart the GNOME Shell by logout the current session

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.