0

I am running XUbuntu 16.04 with a Nvidia 1080ti and 4 Monitors. I use a xrandr script to switch between 3 of them, to work, and the 4th, which is a TV.

Yesterday the System somehow crashed during execution of this script, while running a GPU intense Background Task was running. I ran the script, the 3 Monitors went black, but the 4th never got a Signal. I could not get a Display Output anymore and had to power cycle the System. I think the crash wasn't just the Display System, as Music also stopped playing.

Today I found that apparently the nvidia kernel module does not load anymore. The 1080p TV still gets an okay Looking Output in 1080p, but all of the 3 other Monitors, which are 1440p via DisplayPort, only get a Resolution of 640x480. I also cannot enable more than one at a time.

I've found the message "Failed to initialize the NVIDIA kernel module, please see the Systems kernel log for addititional error Messages" in /var/log/Xorg.0.log

In /var/log/kern.log it says "nvidia: Version magic '4.4.0-139-generic SMP mod_unload modversions ' should be '4.4.0-139-generic SMP mod_unload modversions retpoline ', logger Maybe a few dozen times on System Startup.

Googe has not been helpful with those Messages.

I've tried to use software-properties-gtk --open-tab=4 to select various Driver versions, nvidia, but also the Standard ubuntu Driver. None make any difference, the Problem persists.

I also tried to purge all nvidia Drivers, but this has had no visible effect either.

I also thought this might be About some issues with my xorg.conf or Monitors.xml, but neither of those files seem to exist on my System. Not sure if they should exist.

I have a Windows 7 dual boot, which Shows no signs of Trouble, except for the fact that I somehow don't get the full 144hz of my 144hz Center monitor, but only 85. I suspect that is unrelated however, as it has been like that for a few weeks. It likely was caused by a graphics Driver update on Windows and I was too lazy to fix it, as I have not been playing much lately.

How do I proceed to fix this? I am out of ideas of what to do.

EDIT: I've found some info on the redpotline-thing. Apparently that is an issue that for other has been caused by having a non-Standard GCC Version. I have that, too. However I have it since month with no issue. I also tried to go back to the older gcc via update-alternative, and reinstall various Drivers while that is active, but had no success.

EDIT 2: Purging the nvidia Driver completely gives me the nouvou Driver, and no error Messages in the log, but the available screen Resolution stays at 640x480 and a single screen. Not sure if the Driver is just hopelessly outdated and cant do more, the supports Cards it lists in the log are all ancient, end with the Gefore 8.

I've found a stacktrace in the kernel log that is exactly around the time my monitor switching script crashed it all, it says something About nvidia and acquiring a spinlock. Maybe some Kind of deadlock or timeout occured due to the high gpu load at the time. It's odd though, I've switched Monitors during 100% gpu load before and never had issues.

0

I've fixed it. It was the wrong gcc Version after all. My first attempt at solving it that way used the oldest gcc I had on the System, 4.9, which was the "Auto" Option. Somehow that did not add the retpotline flag to the Driver however. I tried again with gcc 5.4 and that worked.

So if you find the retpotline Thing in your log, make sure you install the Driver only while you have switched to the "Right" gcc Version, which for me was gcc (Ubuntu 5.4.0-ubuntu1-16.04.10) 5.4.0 20160609

Now the open Question remains why the crash caused my Drivers to be recompiled. I have no idea how that happened, but fact is that the Timing in the log entries Looks very much that is what happened. Or something earlier somehow recompiled the Driver and the crash was caused by that. The System had been up for 6 days straight before, Maybe somewhere some automatic update of some Kind kicked in when I wasn't Looking.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.