0

This question already has an answer here:

Photo of screen with erroe

I can't figure out what is wrong with my Ubuntu 18.04. I was trying to set a path for an application in my .profile and restarted the machine. Since then, I've been getting this error on the screen. I tried rebooting Ubuntu changing configuration from the boot menu via the DVD but yet nothing is happening.

What's the problem and how can I fix it?

marked as duplicate by David Foerster, Fabby, Charles Green, Eric Carvalho, Zanna Nov 15 '18 at 18:26

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Can you add the contents of .profile to your question? – Starbuck Nov 14 '18 at 20:31
  • I cannot access anything beyond the image that I have posted. – user1738234 Nov 14 '18 at 20:41
  • I've added a way for you to access .profile in my answer below. – Starbuck Nov 14 '18 at 20:52
1

The problem is lines 32 and 33:

unexpected EOF while looking for matching "

Somewhere on line 32 a " hasn't been closed (or opened), and it's causing an "unexpected end of file". It's hard to say what exactly needs to be changed without being able to read your .profile.

Since you can't get past this error, you'll need to switch to another console with ctrl+alt+f1. Login then open it up with vim /home/moloy/.profile to find the error and edit it.

(vim will show you which line your cursor is on at the bottom and hopefully make things easier to spot with syntax highlighting.)

  • I tried to re-install ubuntu by using a DVD by changing the boot menu priority, but it is not reading from the CD. – user1738234 Nov 14 '18 at 20:45
  • reboot the machine and enter emergency mode and mount file system as read and write and check /home/<username>/.profile file and comment or uncomment 32 line in that file. – JackyChan Nov 14 '18 at 20:50
  • That's separate issue, for another question. Unless you really want a fresh system, reinstalling isn't necessary. – Starbuck Nov 14 '18 at 20:58
  • Wonderful! I'm glad I could help. Those little syntax errors can be really annoying, especially if you're just starting to learn how linux works. – Starbuck Nov 16 '18 at 2:48

Not the answer you're looking for? Browse other questions tagged or ask your own question.