0

Caveat: I'm far from an advanced user. I like Ubuntu for web development and casual use, and generally try to figure things out as the need arises.

After running a routine update (apt update, apt upgrade) and later restarting my ThinkPad Yoga 11e (3rd generation, I believe), my touchpad has stopped working completely. It's listed when I run xinput list, but nothing I've tried so far has managed to restore functionality.

The touchscreen and keyboard still work as expected, and I haven't had a chance yet to test it with Ubuntu booted from a USB stick. --Edit 1: after booting from a USB stick, it appears xinput is showing the wrong device for my touchpad.

Context: at the time it stopped working, I was running 18.04.1 with Unity (ubuntu-unity-desktop), LightDM, and xserver-xorg-input-synaptics. Thinking that Unity and the synaptics driver might have something to do with it, and not getting any helpful search results with so many key phrases, I uninstalled them. Currently running with GNOME, GDM, and xserver-xorg-input-libinput.

--Edit 2: reinstalled Ubuntu and the touchpad worked, then updated and it's back to being completely unresponsive. Prior to updating, xinput list properly showed "SynPS/2 Synaptics TouchPad"; after updating, it once again shows "Synaptics s3203_ver5".

--Edit 3: wiped the drive and reinstalled 16.04. Same results: touchpad worked after installation, failed after updating. Same xinput list results. Reinstalled 18.04 again to start over, and ruled out the kernel as the problem.

Specs:
Ubuntu 18.04.1
GNOME 3.28.2
Kernel 4.15.0-39-generic
Synaptics s3203_ver5 --Edit 1: should be SynPS/2 Synaptics TouchPad

0

Can you try adding to your grub file

GRUB_CMDLINE_LINUX_DEFAULT "psmouse.synaptics_intertouch=0"

It worked for me (Thinkpad T440s with updated 3-buttons Trackpad).

0

It seems my issue was related to this kmod bug, as cited here. Resolved it by preventing kmod from updating on a fresh 18.04 install.

After installing 18.04 from a live USB, I ran sudo apt-mark hold kmod to lock my kmod to version 24, as included in the freshly installed OS. After that, apt update and apt install ran as expected, my touchpad still works, and xinput list returns "SynPS/2 Synaptics TouchPad" as expected.

0

After recent update in 18.04.1 I also start to have issues with not working touchpad and changing brightness with keyboard, this solution for old version of ubuntu fixed it.

To be short, need to add blacklist ideapad_laptop in your /etc/modprobe.d/blacklist.conf file.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.