0

Here's my specs and stuff: https://pastebin.com/w3SCkLAN. I have tried multiple ways to download Steam. First is using the .deb, it required the 32-bit libraries I can't, and don't know how to, install. Second is using the terminal. I downloaded Steam and the Steam update, but after that, it doesn't open. Uninstalled it. What should I do?

Now, it says "Fatal Error: Failed to load steamui.so".

Extra info:

icebunny08@D3CRYPT3D:~$ sudo apt install steam
[sudo] password for icebunny08: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
steam:i386 is already the newest version (1:1.0.0.54+repack-5ubuntu1).
0 upgraded, 0 newly installed, 0 to remove and 267 not upgraded.
icebunny08@D3CRYPT3D:~$ steam
tar: This does not look like a tar archive
xz: (stdin): File format not recognized
tar: Child returned status 1
tar: Error is not recoverable: exiting now
find: ‘/home/icebunny08/.steam/ubuntu12_32/steam-runtime’: No such file or directory
icebunny08@D3CRYPT3D:~$ 
  • I am currently on Ubuntu 18.04.1 – icebunny08 Nov 14 '18 at 18:00
  • I installed steam-installer and steam-launcher. It still requires the 32-bit libraries – icebunny08 Nov 14 '18 at 18:04
  • Now, it says "Fatal Error: Failed to load steamui.so". – icebunny08 Nov 14 '18 at 18:07
  • I think I have worked out a solution for you... plz see answer. – Joshua Besneatte Nov 14 '18 at 18:17
  • Joshua, I have already tried your solution. After updating Steam, it doesn't open. – icebunny08 Nov 17 '18 at 11:44
1

You will need to enable the i386 arch:

$ sudo dpkg --add-architecture i386
$ sudo apt update && sudo apt upgrade --fix-missing

Now make sure your old repo is disabled by running:

$ sudo software-properties-gtk

and look to see if there is a Steam repo in "other software" tab. If so delete it before proceeding.

You can be sure all requirements are installed using:

$ sudo apt install libgl1-mesa-dri:i386 libgl1-mesa-glx:i386

Then you can try to reinstall steam:

$ sudo add-apt-repository multiverse
$ sudo apt update
$ sudo apt remove --purge steam-launcher steam-installer steam-devices steam && sudo apt autoremove
$ sudo apt install steam steam-devices

Finally, if running steam from command line does not work, try launching it from activities window.

More info available here.

  • Doesn't work. pastebin.com/fSz05Dbk – icebunny08 Nov 14 '18 at 18:19
  • Looks like those * I was trying to use didn't work... updating answer now...\ – Joshua Besneatte Nov 14 '18 at 18:23
  • I think you need to make sure to delete the old repo before purging.. I have polished my answer... let me know if it works now. – Joshua Besneatte Nov 15 '18 at 15:54
  • I have done this before. I cancelled it for the mean time because when I did this before, after updating, Steam doesn't open. I have a backup of ./steam and /.local/share/steam or whatever the file path is. – icebunny08 Nov 17 '18 at 1:39
0

I don't know if this will solve your problem but I can't comment yet so...

You need to remove the Steam Repo that was installed with the .deb package, then update apt and remove the old installation. I don't know the command for removing a repository but you can use software-properties-gtk and remove it from the "Other Software" tab.

http://repo.steampowered.com/steam precise InRelease

Then:

sudo apt update
sudo apt purge steam*
sudo apt autoremove

Also, make sure the .steam directory is gone. If its not gone then delete it.

I think the steam-launcher package came from the old repo, on my system the only Steam packages are:

steam:i386
steam-devices
steam-installer

The steam:i386 package is what is installed by sudo apt install steam. I'm not sure, but from the apt descriptions it seems that steam-devices is for using Valve's Steam hardware, and steam-installer is for people trying to install Steam with i386 emulation on other architectures (such as PowerPC).

After you've removed the old repository and installation just do:

sudo apt install steam NO ASTERISK (*)

If it won't install, consider that the graphics PPA you are using might be causing a conflict.

  • I can confirm that steam-devices is what make your controller work. – Joshua Besneatte Nov 15 '18 at 15:53

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.