0

I can't format a USB drive, it says "read only filesystem". I tried mkfs.vfat, wipefs -a, using gparted but nothing worked, always returns "Read-only filesystem". The problem seems to be caused by an HFS+ partition. It seems like even root is not allowed to write on the drive: I tried every terminal command with root privileges an it keeps returning "failed to open for writing: Read-only file system". I'm running Ubuntu 18.10. Anyone can help? Thanks

0

This is a nice tutorial walk through of how to format a USB drive:

https://itsfoss.com/how-to-format-a-sd-card-or-usb-drive-in-ubuntu-12-10/

In short:

  1. sudo apt-get install gparted
  2. sudo gparted
  3. Select your usb drive in the top right of gparted
  4. Make sure to unmount the drive (this is key), right click on the drive and select unmount
  5. Now to can format it, right click on the drive and pick your file system :)

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.