0

I am new to Ubuntu and not very much familiar with all the details.

I followed the instructions here to create a GUI for an EC2 instance: https://medium.com/@s.on/running-ubuntu-desktop-gui-aws-ec2-instance-on-windows-3d4d070da434

The instance runs ubuntu 18.04 LTS. I have also installed ubuntu 18.0418.04 LTS on a PC that I have and I really like the interface.

The problem though is that when I remotely connect to the ec2 instance, the GUI does not look like my PC.

How can I have my ec2 instance have the same GUI?

Here is my PC GUI: pc gui

Here is my ec2 GUI: ec2 gui

Update 1: Here is the log file:

15/11/18 18:14:16 Xvnc version TightVNC-1.3.10
15/11/18 18:14:16 Copyright (C) 2000-2009 TightVNC Group
15/11/18 18:14:16 Copyright (C) 1999 AT&T Laboratories Cambridge
15/11/18 18:14:16 All Rights Reserved.
15/11/18 18:14:16 See http://www.tightvnc.com/ for information on TightVNC
15/11/18 18:14:16 Desktop name 'X' (ip-10-105-54-119:1)
15/11/18 18:14:16 Protocol versions supported: 3.3, 3.7, 3.8, 3.7t, 3.8t
15/11/18 18:14:16 Listening for VNC connections on TCP port 5901
/home/ubuntu/.vnc/xstartup: 11: /home/ubuntu/.vnc/xstartup: vncconfig: not found
/home/ubuntu/.vnc/xstartup: 13: /home/ubuntu/.vnc/xstartup: gnome-settings-daemon: not found
metacity-Message: 18:14:17.292: could not find XKB extension.

(metacity:4631): metacity-WARNING **: 18:14:17.300: Failed to create MetaCompositorXRender: Missing composite extension required for compositing

** (gnome-panel:4628): WARNING **: 18:14:17.354: Failed to register client: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files

** (nautilus:4632): WARNING **: 18:14:17.967: Unable to get contents of the bookmarks file: Error opening file /home/ubuntu/.gtk-bookmarks: No such file or directory

** (nautilus:4632): WARNING **: 18:14:17.967: Unable to get contents of the bookmarks file: Error opening file /home/ubuntu/.gtk-bookmarks: No such file or directory

Update 2:

I got closer by using the following:

#!/bin/sh

export XKL_XMODMAP_DISABLE=1
export XDG_CURRENT_DESKTOP="GNOME-Flashback:GNOME"
export XDG_MENU_PREFIX="gnome-flashback-"

gnome-session --session=gnome-flashback-metacity --disable-acceleration-check &

which gave me this: new desktop

But I am not sure how to modify it to get ubuntu desktop.

Update 3:

This is what I get when I check for my sessions:

Current sessions

So I have different sessions installed, but cannot switch to ubuntu session.

  • It looks like you're using different window managers. The one on your desktop is clearly Gnome. The one on ec2 looks like it might be an older version of gnome. You might want to try doing a do-release-upgrade. – Mark D Nov 15 '18 at 16:17
  • Thanks. I tired "do-release-upgrade" and I got "No new release found"I have posted the log file. I have posted the log file if it helps. – SaTa Nov 15 '18 at 18:19
0

You won't get same GUI. And main reason you can see in log file:

Failed to create MetaCompositorXRender: Missing composite extension required for compositing

Over VNC you don't have composite extension that is required by Mutter / GNOME Shell.

  • Thanks for the hint. I do not see that message in the log. Can you give me a script that creates that log? – SaTa Dec 26 '18 at 16:23
  • What message? About compositing? Check your Update 1 log... – muktupavels Dec 26 '18 at 17:15
  • Sorry, my bad. is the gnome-flashback-metacity the closest I can get in terms of GUI? – SaTa Dec 26 '18 at 17:33
  • Sorry, I don't have answer to that / I don't know. – muktupavels Dec 26 '18 at 17:37
  • Do you know is this a limitation on VNC side? I am wondering because I have done screen sharing in ubuntu through vnc where I can get the ubuntu gnome env I like. – SaTa Dec 26 '18 at 23:37
0

So it looks like you are using different window managers, your ec2 instance is using gnome-flashback and your desktop edition is using Gnome 3. Personally I think you'd be better off using gnome-flashback for a desktop environment inside EC2 so that your lag isn't too bad but if are certain you want to switch window managers to Gnome 3, see this answer for Switching window managers in desktop environments

  • Thanks for the feedback and the insight. I did install ubuntu-dekstop but still cannot switch to it. I did look at the link you provided but it didn't help. I'll update my question to include what session I see installed. – SaTa Nov 19 '18 at 15:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.