5

I have a Lenovo Legion Y530 with W10 and ubuntu 18.04. The laptop had some issues with the battery which were solved by updating the BIOS, which I did from windows downloading the update from the official website of Lenovo.

After that, now Ubuntu can not detect the screen (Windows does). I checked the drivers in Software and Updates and it says that it is using the nvidia 390, and ubuntu-drivers devices lists that one as recommended. Nvidia X server settings also says that I'm using the nvidia one. But if I go to settings->details->about, it shows Intel® HD Graphics (Coffeelake 3x8 GT2).

I did apt purge nvidia* and ubuntu-drivers autoinstall but all the outputs are the same.

How should I proceed?

2
  • Should we assume you don't have the same problem in Windows?
    – user880592
    Commented Nov 14, 2018 at 11:01
  • No, it doesn't happen in windows, sorry for not clarifying.
    – ImanolUr
    Commented Nov 14, 2018 at 11:28

1 Answer 1

5

Turns out that the Secure Boot was activated again, so I just had to go to BIOS menu and deactivate it.

1
  • It's really annoying to deal with all these tiny details :( Thanks for the tip! It worked like a charm.
    – xarlymg89
    Commented Oct 11, 2020 at 12:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .