I have problems getting my Viewsonic VX2025wm LCD monitor with Ubuntu 11.10. I have another monitor which works well (although in VGA mode), but this one refuses to go beyond 640x480. I'm trying to set it at 1680x1050 (60Hz). I'm using the latest NVIDIA drivers on a Geforce GTX 560 TI.

I tried using xrandr using this solution: http://www.linuxjournal.com/content/guerrilla-tactics-force-screen-mode-ubuntu but I get the following error:

Failed to get size of gamma for output default

If I list the available modes, none are higher than 640x480.

I tried a few solutions proposed here: Monitor will not be detected, stuck at 640x480

Forcing the resolution in xorg.conf doesn't work, but the monitor always falls back to 640x480.

I also tried using nvidia-xconfig --mode=1680x1050 but it doesn't work either.

I tried deleting my xorg.conf file, but the monitor still falls back to 640x480.

This guy has the exact same monitor as me but a slightly different problem (he can set it higher than 640x480, but not 1680x1050): Getting screen resolution correct with nvidia drivers

Here is my current xorg.conf:

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 295.20  ([email protected])  Mon Feb  6 22:13:40 PST 2012

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"

Section "Files"

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
        Modes      "1680x1050"

FYI, the monitor has always worked without any problem with any version of Windows. I'm not saying Windows works better, I'm just saying the monitor works normally with another OS.

Thanks for any help. I'm really going crazy here!

  • The solution I posted in the update actually works. I managed to get the EDID data for my monitor through the analog cable, saved it to the hard disk and added the CustomEDID option to xorg.conf. Finally! This solution should work for anyone having problems with their DVI output. Mar 2, 2012 at 5:34
  • 1
    Please post the solution as an answer
    – Panther
    Mar 2, 2012 at 5:53

3 Answers 3


I've had a very similar problem and I got it working reliably by following these steps. Give it a try!


UPDATE: The DVI on the Viewsonic VX2025wm seems to be broken altogether. The monitor isn't propertly recognized in Windows either, but Windows just let me force the resolution without problem. It seems someone else had the exact same problem and had to use a custom EDID fetched from the monitor using a VGA cable instead. http://forums.nvidia.com/index.php?showtopic=73027


For what it's worth, I had an acer monitor stuck at the lowest resolution when using it as a dual monitor off my Asus laptop - relacing the hdmi cable with an hdmi to DVI cable worked. Getting on with my life.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .