I am running xubuntu 18.04.

I recently installed the nvidia proprietary drivers.

I have three monitors.

When I lock my screen using light-locker my left-most monitor turns off and the other two monitors mirror each other at a 800x600 resolution.

I had a similar-but-not-identical problem with my login screen, which I solved: How to adjust display settings for LightDM greeter on 18.04?

How do I apply a similar solution to my lock screen? I'm assuming it's a different configuration file but I can't find where it might be.

Here is the output of light-locker --debug, if it is helpful.

[gs_debug_init] gs-debug.c:106 (21:58:56):   Debugging enabled
[main] light-locker.c:142 (21:58:56):    initializing light-locker 1.8.0
[main] light-locker.c:164 (21:58:56):    Platform:
gtk:        3
systemd:    yes
ConsoleKit: yes
UPower:     yes
[main] light-locker.c:196 (21:58:56):    Features:
lock-after-screensaver: yes
late-locking:           yes
lock-on-suspend:        yes
lock-on-lid:            yes
settings backend:       GSETTINGS
[main] light-locker.c:198 (21:58:56):    lock after screensaver 0
[main] light-locker.c:199 (21:58:56):    late locking 0
[main] light-locker.c:200 (21:58:56):    lock on suspend 0
[main] light-locker.c:201 (21:58:56):    lock on lid 0
[main] light-locker.c:202 (21:58:56):    idle hint 0
[init_session_id] gs-listener-dbus.c:2193 (21:58:56):    Got session-id: /org/freedesktop/login1/session/c2
[init_session_id] gs-listener-dbus.c:2198 (21:58:56):    Got sd-session-id: c2
[init_seat_path] gs-listener-dbus.c:2279 (21:58:56):     Got seat: /org/freedesktop/DisplayManager/Seat0

1 Answer 1


Turns out this a reported bug in the proprietary NVidia proprietary drivers: https://bugs.launchpad.net/ubuntu/+source/light-locker/+bug/1760068.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.