3

I recently switched from Windows to Ubuntu 18.10 with this Notebook, and despite is not a serious problem I noticed that often the fan turn on for ~3 sec. then turn off for ~5 sec. and then turn on again following this pattern.

I've taken a look to system monitor and I noticed that every time it happens, is because one of the cores of the CPU has gone to 100% of usage for few seconds (while the others are almost idle), like it shows the pic below:enter image description here

I don't get why sometimes one core goes to 100% (for example it happens when I'm just running Firefox with few tabs on the process Web Content) and if I can do sometimes to avoid it (at least to the fan, beacuse the continuosly turn on/off it's a bit annoying).

Thanks!

UPDATE
It's a little bit difficult to reproduce the problem when I try. Anyway, testing again showed me that sometimes fans activate in the same way also when no CPU reaches 100% of utilization (just lower peaks). Running ps aux --sort=-pcpu | head as @Fabby in the comment said, gave me the following :

  1. ollaw 2053 15.1 0.7 443272 126220 tty2 Sl+ nov28 17:00 /usr/lib/xorg/Xorg vt2 -displayfd 3 -auth /run/user/1000/gdm/Xauthority -background none -noreset -keeptty -verbose 3
  2. ollaw 7543 12.0 2.4 2532128 402472 tty2 Sl+ 01:03 1:22 /usr/lib/firefox/firefox -new-window
  3. ollaw 7612 10.8 2.5 1978608 413444 tty2 Sl+ 01:03 1:13 /usr/lib/firefox/firefox -contentproc -childID 1 -isForBrowser [etc....]
  4. Almost the same as 3
  5. ollaw 2234 5.3 1.4 3300616 244520 tty2 Rl+ nov28 5:58 /usr/bin/gnome-shell


Other informations:

  • No error in dmesg since someone in the answer asked.
  • Currently using nvidia-driver-390 drivers.
  • Nvidia is in intel-mode (but pretty sure it happens also in nvidia-mode).
  • Does it happen when other programs except FireFox is running? It could be one of the tabs in FireFox and closing that one would solve the issue, but we cennot tell you which one... – Fabby Nov 22 '18 at 9:21
  • It looks like without Firefox happens less frequently but I'm not totally sure. Anyway, it's happened several time in general, with different tab open, so I don't think that's a particular tab. – Ollaw Nov 23 '18 at 0:24
  • 3
    But it is only with FireFox? (We need to drill down into where the problem is coming from: is is xorg that has the high CPU or FireFox itself?) use ps aux --sort=-pcpu | head on the cli and edit your post and provide that output, please... – Fabby Nov 23 '18 at 16:33
  • If it is only an issue using firefox check about:support and check the status of the “multiprocess Windows” option; it should be anbled if not check this: omgubuntu.co.uk/2017/05/ubuntu-firefox-multiprocess-enable – db429 Nov 26 '18 at 22:23
  • What drivers are loaded for your Nvidia graphics card? – Michael Prokopec Nov 27 '18 at 4:41
1

Use a tool like top during the spikes to see which processes are using up your CPU and then kill them (by closing the app or with the kill CLI tool).

Or if it's a kernel issue, you would see some errors in dmesg, so at least run the command. If there's some text that's red colored or looks like an error that could be the problem.

  • thanks for the advice, i will soon add more details to the question and i will include that – Ollaw Nov 28 '18 at 10:24
0

Whenever a process needs resources and the process is not capable of using multiple threads concurrently the load will be handled by a single thread. This, in turn, puts load on a single core/thread of the CPU which in turn gets hot leading to an increased fan spin. This increase is especially high if the CPU was in a low power state prior to the resource request because then the temperature change is largest.

You could look either into CPU governors or into fan profiles.

Another approach may be to try to understand exactly under which circumstances which process spikes - it could be a bug or there could be room for improvement.

0

I suggest, shutting down the computer, removing the power cord. If this is a laptop, pull the battery. Open the case, removing the CMOS (RTC) battery. Counting to 10 before re-installing the battery. Put all power back into the 'puter.

At the radio frequencies of modern computers, the black arts come into focus. Once and a while, something is not getting to ground, even during power down.

  • What do you mean by At the radio frequencies of modern computers, the black arts come into focus. Once and a while, something is not getting to ground, even during power down.? – Nonny Moose Nov 29 '18 at 0:35
  • All electronics operating at common CPU speeds generate micro amounts of RF signals. This is not a health hazard. When literal billions of bits are moving twixt CPU, GPU, Motherboard, DRAM, and hdd, there is a possibility of 1 bit in 10 billion or 100 billion not getting to either one or zero. That is what lead to my suggestion to bring the equipment to absolute ground. – Mark Preston Dec 14 '18 at 17:59
0

Try turning off your nVidia card:

sudo prime-select intel

Then reboot.

Also it could simply be a glitch with your machine design: G752VT Left side fan keeps turning on and off!

  • I'm currently using intel mode, not sure but I'm pretty sure it happens both with Nvidia and intel mode – Ollaw Nov 28 '18 at 10:10
  • I read that nVidia had a function called something like Mizer that could effect fan turning on/off frequently. My Alienware laptop with GTX 970M has no such problem though... – WinEunuuchs2Unix Nov 28 '18 at 11:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.