I'm currently running Ubuntu 18.04 on my Dell XPS 15 (9570) with the 4K display. I am trying to use the TB16 dock to connect to an external display at work that is 1920x1080 and I'm facing the seemingly comming "hiDPI" issues.

The xrandr commands found here work well and I can setup the external monitor to be reasonably-sized while also running my 4K display at full-res. However, as soon as I scale with xrandr I get a flickering mouse on my main display.emacs

Here's the script I run to set up my external display:

# Set up frame buffer (add up the mode OR scale-from parameters below)
xrandr --fb 7680x2160 &&

# Set up laptop monitor
xrandr --output eDP-1 --mode 3840x2160 --rate 60 --primary &&

# Set up external display(s)
# My configuration only has a 1080p display to the right of my laptop
xrandr --output DP-1-1 --mode 1920x1080 --scale-from 3840x2160 --panning 3840x2160+3840+0 --right-of eDP-1

The solution to this is found here

That works great, so now I have seemingly solves the HiDPI + LoDPI external display problem and the mouse flickering problem. And then I open emacs... and weird graphical glitches start to occur. The cursor causes characters to disappear permanently until I change lines, etc.

Any ideas of how to fix this last issue with emacs?

1 Answer 1


I actually solved the problem before I posted this, but since I spent so many hours figuring this out today I figured I would post the question and answer it so that it may help others that stumble here in the future:

This issue seems to go away if you install emacs26 (which appears to implement double-buffering which may help mitigate this issue).

I uninstalled emacs25 and installed emacs26 and no issues yet...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.