First off I upgraded my Wifi card from a ralink to a Intel Ultimate-N 6300 and also had to install a Modded bios so the computer would accept the wifi card. I can get my wifi to connect in Windows but when I try to install any linux tried Ubuntu's, Crunchbang, Archbang etc. the wifi card is recognized but when i try to connect to any router I get an endless loop of it trying to connect. if the router had a wep key it will go in an endless loop for about 45 seconds then re ask for the password if the router doesnt have a password it will just sit in an endless loop saying connecting. The computer is a dv6-6135dx with a AMD chipset has the 3500m processor in it 6620g integraded graphics with a 6750m graphic card also. Could it be a conflict between the AMD chipset and the wifi card needing a intel chipset driver? Here is some more detail.

03:00.0 Network controller [0280]: Intel Corporation Centrino Ultimate-N 6300 [8086:422b] (rev 3e)
    Subsystem: Intel Corporation Centrino Ultimate-N 6300 3x3 AGN [8086:1101]
    Flags: bus master, fast devsel, latency 0, IRQ 53
    Memory at f0200000 (64-bit, non-prefetchable) [size=8K]
    Capabilities: <access denied>
    Kernel driver in use: iwlagn
    Kernel modules: iwlagn

also have done:

sudo rmmod iwwlagn
sudo modprobe iwlagn bt_coex_active=0

this allows me to connect to the wifi but only on that session of Ubuntu if i restart i have to go back into terminal and retype also i am noticing slow speeds after doing that. Any suggestions?

What I've tried:

  • According to this bug these cards might have a hard time when in 802.11n mode. Doing a sudo modprobe iwlagn 11n_disable=0 just makes it get stuck in an endless loop trying to connect.

If you have modprobe parameters you already know work:

If that modprobe parameter works for you, as root add a file in modprobe.d that makes the setting persist, like this:

  1. As root with your text editor of choice make a new file:

  2. In that file add the line:

    options iwlagn bt_coex_active=0
  3. Save and reboot.

Wireless N can be finicky on a lot of cards, but if you found modprobe settings that work for you...just make them persist. It doesn't solve the slow problem, but it does get you running consistently.

If you don't:

Disabling hardwarecrypto:

Some users have reported that N support gets much more reliable using software you might try

options iwlagn hwcrypto=0

instead of the coex option.

Disabling n:

As was already suggested by Jorge Castro:

options iwlagn 11n_disable=0
  • is there any other way we can fix this? my laptop disconnects from the internet every like 2 minutes then reconnects after 2 more minutes – Jerry Mar 2 '12 at 21:09

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.