I have Ubuntu 18.04 dual booted with Windows 10. Windows 10 shows full 8 GB RAM.

But in Ubuntu it shows only 6.8 GB.

"About" screenshot

Is there any way to make it near 8 GB or is this natural?

~$ free
              total        used        free      shared  buff/cache   available
Mem:        7097484     1775180     3633172       67964     1689132     4994508
Swap:       1000444           0     1000444

After turning the swap area off,

~$ free
              total        used        free      shared  buff/cache   available
Mem:        7097484     1776700     4761256      111464      559528     4949096
Swap:             0           0           0

Output

~# dmesg | grep -i memory:
[    0.000000] PM: Registered nosave memory: [mem 0x00000000-0x00000fff]
[    0.000000] PM: Registered nosave memory: [mem 0x00087000-0x00087fff]
[    0.000000] PM: Registered nosave memory: [mem 0x000a0000-0x000bffff]
[    0.000000] PM: Registered nosave memory: [mem 0x000c0000-0x000fffff]
[    0.000000] PM: Registered nosave memory: [mem 0x09b00000-0x09dfffff]
[    0.000000] PM: Registered nosave memory: [mem 0x09f00000-0x09f09fff]
[    0.000000] PM: Registered nosave memory: [mem 0x6427a000-0x64b79fff]
[    0.000000] PM: Registered nosave memory: [mem 0x6b58f000-0x6b78efff]
[    0.000000] PM: Registered nosave memory: [mem 0x6b78f000-0x6d78efff]
[    0.000000] PM: Registered nosave memory: [mem 0x6d78f000-0x6f78efff]
[    0.000000] PM: Registered nosave memory: [mem 0x6f78f000-0x6f7fefff]
[    0.000000] PM: Registered nosave memory: [mem 0x6f800000-0xafffffff]
[    0.000000] PM: Registered nosave memory: [mem 0xb0000000-0xf7ffffff]
[    0.000000] PM: Registered nosave memory: [mem 0xf8000000-0xfbffffff]
[    0.000000] PM: Registered nosave memory: [mem 0xfc000000-0xfebfffff]
[    0.000000] PM: Registered nosave memory: [mem 0xfec00000-0xfec00fff]
[    0.000000] PM: Registered nosave memory: [mem 0xfec01000-0xfec0ffff]
[    0.000000] PM: Registered nosave memory: [mem 0xfec10000-0xfec10fff]
[    0.000000] PM: Registered nosave memory: [mem 0xfec11000-0xfed7ffff]
[    0.000000] PM: Registered nosave memory: [mem 0xfed80000-0xfed80fff]
[    0.000000] PM: Registered nosave memory: [mem 0xfed81000-0xfedfffff]
[    0.000000] PM: Registered nosave memory: [mem 0xfee00000-0xfee00fff]
[    0.000000] PM: Registered nosave memory: [mem 0xfee01000-0xff7fffff]
[    0.000000] PM: Registered nosave memory: [mem 0xff800000-0xfff4ffff]
[    0.000000] PM: Registered nosave memory: [mem 0xfff50000-0xffffffff]
[    0.000000] Memory: 6929972K/7238032K available (12300K kernel code, 2472K rwdata, 4248K rodata, 2408K init, 2416K bss, 308060K reserved, 0K cma-reserved)
[    0.039763] Freeing SMP alternatives memory: 36K
[    1.147121] Freeing initrd memory: 54212K
[  141.519341] Freeing unused kernel memory: 2408K
[  153.310684] Freeing unused kernel memory: 2008K
[  153.317976] Freeing unused kernel memory: 1896K
[  153.869546] [TTM] Zone  kernel: Available graphics memory: 3548742 kiB
[  153.869547] [TTM] Zone   dma32: Available graphics memory: 2097152 kiB
  • 16
    Some of the RAM is probably reserved for graphics. – mikewhatever Nov 13 at 15:40
  • see here – Doug Smythies Nov 13 at 15:46
  • But I have Radeon 560X (4GB VRAM), by default it is showing AMD Raven(the integrated graphics), can I change it to use Radeon? @mikewhatever – Abraham Francis Nov 13 at 15:48
  • 1
    But here there is a difference of more than 1 GB right? @Doug Smythies – Abraham Francis Nov 13 at 15:53
  • Well, edit your question and add the relevant stuff from /var/log/kern.log. The answer I pointed you to was just so that you would know what to look for. See also here. – Doug Smythies Nov 13 at 15:57

This line:

[    0.000000] Memory: 6929972K/7238032K available (12300K kernel code, 2472K rwdata, 4248K rodata, 2408K init, 2416K bss, 308060K reserved, 0K cma-reserved)

indicates that BIOS is giving the kernel 7238032K of memory. The rest of the memory is being used by the BIOS:

8,388,608 K Total - 7,238,032 K Kernel = 1,150,576 K reserved by BIOS.

That is an unusually large amount for BIOS to reserve. You would have to look at your BIOS settings to perhaps try to figure out why.

  • 7
    It is possible that the BIOS is reserving a large amount of memory for an on-board GPU (despite it not being used, in favour of the add-on one with its own RAM supply). That would be the first set of settings I'd look at if a BIOS was holding back such a large chunk of physical RAM from the OS. – David Spillett Nov 14 at 11:35

From: Why my acer nitro 5 (AN515-42, Radeon RX 560X) 8gb ram but its just 6.9gb ram usable?

This can only be "fixed" in the bios! But not all bios allow you to change the pre-allocated memory of the video card, because there is a risk of the notebook turning a brick! Can you take a picture of this setting?

Ubuntu is using your CPU's integrated graphics, which consumes ~1.1GB of system memory, whereas Windows is using the discrete graphics, which consumes no system memory.

I'm not sure why Ubuntu defaults to the iGPU, but you can possibly get it to use the dGPU by ensuring that your AMD GPU driver is up to date. If that does not work, you can try using the hybrid graphics feature to switch between GPUs, but do note that this feature is very experimental and very low-level and could easily prevent your Ubuntu install from booting if your hardware setup isn't correctly supported.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.