I used to run 16.04 and used a PPA to install Python 3.6. I've since done the upgrade to 18.04 where Python 3.6 is supported officially, but I have noticed that vim can't be installed:

$ sudo apt install vim
The following packages have unmet dependencies.
 vim : Depends: libpython3.6 (>= 3.6.4~rc1) but it is not going to be installed

If I try to install python packages, I get version conflicts:

$ sudo apt install libpython3.6
The following packages have unmet dependencies.
 libpython3.6 : Depends: libpython3.6-stdlib (= 3.6.6-3~18.04.york0) but 3.6.7-1~16.04.york3 is to be installed

If I try to remove python for re-installation, then it wants to remove dozens of dependent applications too.

How can I reset my installation of Python 3.6 to the official Ubuntu one?


Looks like this is no longer an issue, as version 3.6.7-1~18.04 is available upstream and this overrides the PPA version, and I can directly upgrade to it.

  • 1
    The version numbers used in the PPA are higher than the version numbers in the Ubuntu repositories, so the real 18.04 Python packages were not installed. This is why we recommend uninstalling all PPA software before doing a release-upgrade. There is no 'reset'. Tell apt to install the specific version of Python in Ubuntu 18.04 (currently 3.6.5-3ubuntu1). Downgrading is not supported, so it might work, might not. Back up your data first. – user535733 Nov 13 '18 at 14:28

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.