0

sudo startx will work, but startx will not.

I can see the .Xauthority file in the root directory, but man says it should be located in /run/gdm

I know the problem has something to do with permissions and the location of the file, but I can't find where to change configuration of the default to be NOT in the // directory. I am going to try adding setting in the custom.conf file with a document I found on x.org

:/$ startx

xauth: timeout in locking authority file //.Xauthority

(EE)

Fatal server error:

(EE) Cannot open log file "//.local/share/xorg/xorg.0.log"

(EE)

(EE)

Please consult the The X.org Foundation support at http://wiki.x.org for help

(EE)

xinit: giving up

xinit unalble to connect to X server: Connection refused

xinit: server error

xauth: timeout in locking authority file //.xauthority

0

Indeed the problem was related to .xauthority being in // which is not accessible by a normal user. I never found where the "default" setting was located, but thought about why it might be there when it is not supposed to be, and I did not specifically point it there.

I began to think about what was different that might cause the issue. So although I had followed what I thought was a careful explanation for changing my user name and home directory, I skipped a step... setting my new home directory with usermod.

So, sure enough when I examined $HOME, it was looking at my old directory with the username that no longer existed as I had changed the directory name to match my new user name.

Once I corrected that issue. All works as it should.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.