7

I'm trying to install SQL Server 2017 on Ubuntu 18.10 and encountering an error that libjemalloc1 isnt available. I've seen another answer that says that libjemalloc1 should be in universe for 18.04, but it doesnt look like it's available for 18.10 in ubuntu universe. Is there a solution for this? Has anyone done anything to get it working?

  • Yes there is a solution: The libjemalloc1 package was replaced in 18.10 with libjemalloc2. – user535733 Nov 13 '18 at 4:08
  • thanks, but it still says i need libjemalloc1 even though i installed libjemalloc2 – Joshua K Nov 13 '18 at 4:11
  • 2
    According to docs.microsoft.com/en-us/sql/linux/…, SQL Server 2017 is not supported by Microsoft upon Ubuntu 18.10. Since MS owns the software and created their own deb package to distribute, then MS could provide the updated package compatible with 18.10....if they wish to. Talk to MS support. – user535733 Nov 13 '18 at 4:21
  • ah, that looks like an answer to me. i see. – Joshua K Nov 13 '18 at 4:23
  • 1
    Look at the docker version of sqlserver for linux, run without issues with little to none configuration. – bistoco Dec 5 '18 at 17:30
10

I'm assuming you've followed the installation steps given on Microsoft's SQL server installation page right upto the point where you faced the error.

Here is a workaround:

  1. Download the latest version of libjemalloc (this one is for Ubuntu 18.04) from this mirror here - http://ftp.osuosl.org/pub/ubuntu/pool/universe/j/jemalloc/libjemalloc1_3.6.0-11_amd64.deb
  2. Install it: sudo dpkg -i libjemalloc1_3.6.0-11_amd64.deb
  3. Now run the apt command to install ms-sql server: sudo apt-get install mssql-server

Hope this works for you.

| improve this answer | |
  • 1
    Thanks Sandeep. This allowed me to install it. Now I need to overcome this error Sqlcmd: Error: Microsoft ODBC Driver 17 for SQL Server : TCP Provider: Error code 0x2746. Sqlcmd: Error: Microsoft ODBC Driver 17 for SQL Server : Client unable to establish connection. – Joshua K Dec 8 '18 at 22:52
2

I have found that MSSQL is also compatible with libjemalloc2. If you prefer to not install older packages, you can instead rebuild Microsoft's package with updated dependencies as outlined here: How do I install MS SQL for ubuntu 18.04 LTS?

Note that you will need to also run

sed -i -e 's#libjemalloc1#libjemalloc2#g' newpkg/DEBIAN/control

in step 4 to update the libjemalloc dependency so that it will work in Ubuntu 18.10.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.