1

I know this kind of problem was asked many times, but I can't really find a solution for my problem and have no clue where to go.

I'm using Oracle virtualbox, and here is my environment.

  • Guest: Ubuntu 16.04 LTS
  • Host: Windows 10

This is the network setting for Ubuntu. I do need to access Ubuntu from Windows, so I set the Bridge Adapter. enter image description here Here is the setting for /etc/network/interfaces

source /etc/network/interfaces.d/*

auto lo
iface lo inet loopback

auto eth0
iface eth0 inet dhcp

I tried to take a screenshot of "Edit Connection" dialog but it gives me a black image and didn't work. So I list up the info below,

Ethernet tab

  • Device [eth0]
  • Cloned Mac address [blank]
  • MTU [automatic]
  • Wake on LAN [Default]
  • 1
    The default NAT mode should work. virtualbox.org/manual/ch06.html – GabrielaGarcia Nov 13 '18 at 2:32
  • Thanks, yes it does work with NAT mode, but I need to access the Ubuntu via ip address since it has a web server on it. Do I need to set up port forwarding for it? – Yoo Matsuo Nov 13 '18 at 2:54
  • Oh wow, I tried some port forwarding setting then it just works. – Yoo Matsuo Nov 13 '18 at 2:56
  • 1
    Yes, that's it. With bridged mode you would need a dedicated network device. – GabrielaGarcia Nov 13 '18 at 2:57
  • The bridge adapter used to work for a long time, but it suddenly stopped working for some reason. Anyway thank you very much for your help – Yoo Matsuo Nov 13 '18 at 3:00
1

As @GabrielaGarcia suggested to change the NAT mode, so I switched to "NAT" then set port forwarding at "Port Forwarding" in "Advanced" pane like the following.

Name    Protocol Host IP      Host Port  Guest IP   Guest Port
Rule1   TCP      192.168.56.1 80         10.0.2.15  3000

Now I can access the web server on the Ubuntu guest from the Window host by typing "http://192.168.56.1".

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.