4

I have a problem with the system printing service:

My usb printer used to work just fine, and then I tried to a setup print-server - the whole system hanged up, and after reboot, no matter what I do, I have this message from the GUI settings for printers ...

System printing service not available: system printing service not available

I was trying to restart cups.service and cups.socket as advised in :

Ubuntu 18.04 LTS -- Printing Service Not Available Printing service not available

and cups.socket stays "green" until I look up into the GUI settings for printers, which seems to do something that resets cups.socket again ...

Here is a screenshot of the "best" cups situation: services are not dead

and that's how it looks like right after I check out the GUI printing settings: services fail

I also tried to reinstall cups, - no luck here either.

system info

Any help/advice is appreciated, as I really don't want to reinstall the system, and chances are everything would crash again after I attempt to setup the print-server ...

1

I had the same problem. The solution given in this link solves the problem.

There is a default configuration file which should be installed in /usr/share/cups/cupsd.conf.default so I ran:

sudo cp /usr/share/cups/cupsd.conf.default /etc/cups/cupsd.conf
sudo service cups restart
1
  • systemctl status cups.socket is still failing, but the rest seems to be working! cups is back; printers sections in settings is back etc. Looks like I did something wrong the first time I've tried it. – sergpolly Jan 6 '19 at 5:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.