1

I am running Ubuntu 18.04 on a carbon X1 which has an integrated IR camera, and an integrated ordinary webcam.

However, devices such as Skype and Chrome have mysteriously only started recognizing the IR camera. They have previously successfully found the regular webcam, but on latest reboot the webcam is not even selectable in these applications.

I understand from here that there are tools for identifying the names of my multiple camera peripherals.

What are the command line tools for restarting the webcam/resetting if some other application is holding on to it? How can I force Cheese/skype/chromium to acknowledge the normal camera exists?

(Additionally, can I make the machine completely ignore the IR Camera? It is essentially never what I want, but seems to be an Ubuntu default.)

  • Do both cameras show up as separate devices (using the commands you linked to)? – danzel Nov 13 '18 at 8:43
  • Yes. And a reboot solved this, but I'd looking for an equivalent of restarting the network when that gets fishy, rather than having to reboot whole machine. – Mittenchops Nov 13 '18 at 14:25
  • You can remove and insert the kernel module that is responsible for your webcam. Most USB webcams (integrated cams are usually connected via USB internally) are handled by uvcvideo, so sudo modprobe -r uvcvideo followed by sudo modprobe uvcvideo is probably what you're looking for. However, I'd be more concerned about the application that obviously is using your webcam without your consent. – danzel Nov 14 '18 at 14:30
  • I'm having this same issue; part of the problem seems to be that the IR camera is set to /dev/video0. I've found that I can confirm the standard camera works properly by adjusting preferences with Cheese, but I still haven't figured out how to set the default behavior. – zzu Dec 13 '18 at 4:39
0

The script presented here worked for me. It changes the device name of the IR camera and creates a symlink in its place that points to the standard camera. I added it to my crontab as a @reboot, and it works like a charm.

0

I had the same problem and disabled the IR camera by detaching the driver at startup from the usb device with usb_modeswitch. Also my solution uses the vendor id and product id, so it doesn't accidentally touch anything else if the system configuration changes.

My solution is here: How do I change the default webcam?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.