1

I am trying to install WIFI driver.

When trying to install firmware-misc-nonfree package I get this error:

ham@ubuntu:~$ sudo  apt-get install firmware-misc-nonfree
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package firmware-misc-nonfree is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

UPDATE :

(1) I tried this solution but it didn't work for me.

(2) When I exucated this command lspci -k | egrep -i "Wireless|Network|Ralink|RT3290" -A4 I didn't get any output

The output of this command lsusb -t is:

/:  Bus 02.Port 1: Dev 1, Class=root_hub, Driver=uhci_hcd/2p, 12M
    |__ Port 1: Dev 2, If 0, Class=Human Interface Device, Driver=usbhid, 12M
    |__ Port 2: Dev 3, If 0, Class=Hub, Driver=hub/7p, 12M
        |__ Port 1: Dev 4, If 0, Class=Wireless, Driver=btusb, 12M
        |__ Port 1: Dev 4, If 1, Class=Wireless, Driver=btusb, 12M
/:  Bus 01.Port 1: Dev 1, Class=root_hub, Driver=ehci-pci/6p, 480M
5
  • The link shows a Debian package, not Ubuntu. Some packages are common but not all.
    – user880592
    Nov 12, 2018 at 9:23
  • 1
    If installing firmware-misc-nonfree works in Debian then, I Ubuntu, you can try to install linux-firmware (if not installed yet), reboot and test. That old card should work out of the box though. Also because it's very old and not very good even when it was new, you should consider obtaining a new one. The cheapest you can find is likely to work much better that that one.
    – user880592
    Nov 12, 2018 at 11:04
  • Thank you, I tried installing linux-firmware package if that what you meant then I tried to install the driver again, but didn't have luck I am afraid. maybe it's time to get new card I guess.
    – Ham
    Nov 12, 2018 at 11:15
  • As far I can see the RT3290 is mentioned inside rt2800pci.ko kernel module, it needs firmware /lib/firmware/rt3290.bin from linux-firmware. Please add output of lspci -k | egrep -i "Wireless|Network|Ralink|RT3290" -A4 and lsusb -t to the question.
    – N0rbert
    Nov 12, 2018 at 20:27
  • Already tried the steps in that link none of them worked for me
    – Ham
    Nov 14, 2018 at 9:32

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.