1

I am running Ubuntu Server 18.04 and want to install opendjdk-8-jdk. I have tried doing these steps (referring to this).

sudo add-apt-repository ppa:openjdk-r/ppa
sudo apt-get update
sudo apt-get install openjdk-8-jdk

But I am still getting this:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package openjdk-8-jdk

I specifically want openJDK rather than Oracle-Java-Kit that some repositories offer.

Thank you.

4
  • The package name is openjdk-8. There's no package named openjdk-8-jdkin that repo.
    – user880592
    Nov 12, 2018 at 1:33
  • @GabrielaGarcia tried that too. No luck.
    – Jay Patel
    Nov 12, 2018 at 1:37
  • I think I just found the reason. Itś for older releases only. You need openjdk-11 for Ubuntu 18.04. But the guide is wrong anyway.
    – user880592
    Nov 12, 2018 at 1:44
  • Possible duplicate of How do I enable the "Universe" repository?
    – N0rbert
    Nov 12, 2018 at 20:14

1 Answer 1

2

I suggest you remove the ppa and enable the universe repo instead.

apt policy openjdk-8-jdk
openjdk-8-jdk:
  Installed: (none)
  Candidate: 8u181-b13-1ubuntu0.18.04.1
  Version table:
     8u181-b13-1ubuntu0.18.04.1 500
        500 [my local mirror]/mirror/us.archive.ubuntu.com/ubuntu bionic-updates/universe amd64 Packages
        500 [my local mirror]/mirror/us.archive.ubuntu.com/ubuntu bionic-security/universe amd64 Packages
     8u162-b12-1 500
        500 [my local mirror]/mirror/us.archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
1

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .