10

I tried installing TLP in ubuntu 18.04 using the command line

sudo add-apt-repository ppa:linrunner/tlp

But I get the following error:

Image

How do I solve this problem?

4
  • 1
    Actually the PPA you added has no software for your Ubuntu release. As the comment above suggests, install it normally AND remove all those old PPAs you've been adding.
    – user880592
    Nov 11, 2018 at 14:42
  • I just installed ubuntu few days back and I am complete beginner. so how do I install the correct PPA ?
    – Rima
    Nov 11, 2018 at 14:43
  • @GabrielaGarcia so should I uncheck the boxes for all the PPAs from software and updates?
    – Rima
    Nov 11, 2018 at 14:46
  • 3
    You don't install any PPA for TLP. TLP is available at the official repositories and can be installed like anything else you find in Ubuntu Sofware. And, yes, you should definitely remove all those PPAs.
    – user880592
    Nov 11, 2018 at 14:47

2 Answers 2

19

You are reading old instructions off the internet. tlp is included in Ubuntu's universe repository so all you need to type is:

sudo apt install tlp

If you want to utilize the Radio Wizard also use:

sudo apt install tlp-rdw

Thinkpad users can install optional packages for battery threshold levels:

sudo apt-get install tp-smapi-dkms acpi-call-dkms

Source: Welcome to TLP!

7
  • Thanks a lot. How effective is TLP in extending battery life?
    – Rima
    Nov 11, 2018 at 14:56
  • 1
    @Rima I run my laptops plugged in 24/7 but I've heard others say how it extends from 4 hours to 10 hours after all power saving features are enabled, not just in tlp but also in gnome / unity where screen is dimmed after 10 seconds of inactivity, etc. Nov 11, 2018 at 15:30
  • 2
    @Rima: Could you please open a new question if you have a new or follow-up question? The comment section is not suitable or meant for new questions or extended discussion. You’re welcome to send me a comment with a notification to draw my attention to it. Thanks. Nov 11, 2018 at 20:57
  • @DavidFoerster Thanks but my problem has been solved now. :)
    – Rima
    Nov 12, 2018 at 8:02
  • According to TLP's documentation, the Thinkpad packages are optional for more control.
    – Alex
    Dec 29, 2018 at 5:44
2

For a person who is more into the UI, do the following.

$ sudo add-apt-repository ppa:linuxuprising/apps
$ sudo apt-get update
$ sudo apt-get install tlpui

ui

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.