I just installed Ubuntu Server (Bionic Beaver) on a new PC.

It seems like my internet connection does not work at all (pinging Google does not work and the orange LED on the ethernet port lights constantly), so I did some research on Google (via another PC...).

I found out that this could be an incompatible driver version.
Ubuntu 18.04 LTS comes with Linux Kernel 4.15 (https://wiki.ubuntuusers.de/Bionic_Beaver/).
My NIC: Realtek 8111HS

As I have absolutely no experience with drivers and that kind of things, I visited some webpages and found the following:

So the steps I would take to resolve my problem are the following:

  • Take the 'r8168_8.045.08.orig.tar.bz2' file from here, put it onto a USB stick, plug the stick into the Ubuntu PC, copy the file to the root folder (extract) and execute autorun.sh with root rights (or basically, do everything as mentioned in the README).

Is that correct? Will everything work after that? Do I still have to patch anything or uninstall the old driver or reload anything? Will it work? Are my assumptions correct?

I know, this question might be a little long, however I think it was more important to be accurate than keeping the answer short and (maybe) forgetting something.

Edit: Just found out that v8.046 is part of Ubuntu Cosmic. Also, I configured my network by editing the yaml file in /etc/netplan with DHCPv4 as described here.(and with correct indentation!)

The result of lspci -nnk | grep 0200 -A3:

02:00:0 Ethernet controller [<red>0200</red>]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 15)
    Subsystem: Gigabyte Technology Co., Ltd. Onboard Ethernet [1458:e000]
    Kernel driver in use: 8169
    Kernel modules: r8169

The Netplan configuration file (YAML):

  version: 2
  renderer: networkd
            addresses: []
            dhcp4: true
  • See this also.
    – Vijay
    Nov 11 '18 at 12:04
  • You're right, I also came across that. Anyways, did I choose the right driver to install? Nov 11 '18 at 12:05
  • I think so. Are you sure that the ethernet is configured rightly. Check at settings > Network > Wired > Settings (the wheel on the right).
    – Vijay
    Nov 11 '18 at 12:15
  • I'm running Ubuntu Server. Theres no GUI. @Hobbyist Nov 11 '18 at 12:15
  • 1
    Please edit your question to add the result of the terminal command: lspci -nnk | grep 0200 -A3 Welcome to Ask Ubuntu.
    – chili555
    Nov 11 '18 at 12:56

I don't believe the indentation is correct. Please try:

  version: 2
  renderer: networkd
      dhcp4: true

Follow with:

sudo netplan generate
sudo netplan apply

Assuming there are no errors or warnings, reboot and you should be connected.

Reference: /usr/share/doc/netplan.io/examples/dhcp.yaml

  • Correct. And I had to change the interface name as well. Thanks for your patience! Nov 16 '18 at 14:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.