Bluetooth not finding any devices in Ubuntu 18.04. I tried different solutions that were found on the internet but with no success.

After Bluetooth is enabled, it keeps searching for devices until it is turned off. All the devices that I am trying to connect with are fully functional, they were paired with other OS and working fine.

  • Please edit your question and add output of lspci -knn | grep Net -A3; lsusb; rfkill list terminal command.
    – Pilot6
    Feb 8, 2019 at 20:22

7 Answers 7


In my case the BCM43142A0-0a5c-21d7.hcd was missing. Try this command:

dmesg | grep -i 'blue'

If you get:

Bluetooth: hci0: BCM: patch brcm/BCM43142A0-0a5c-21d7.hcd not found

then you have same problem.

Download the BCM43142A0-0a5c-XXXX.hcd file from this GitHub repo; replace XXXX with the exact name that appears in your error message, in this case 21d7, but it could be different for your device.

After that perform:

sudo cp  BCM43142A0-0a5c-21d7.hcd /lib/firmware/brcm/BCM43142A0-0a5c-21d7.hcd
sudo modprobe -r btusb
sudo modprobe btusb

Shut down your PC and restart and it should work.

You might find these answers useful as well:

  • 1
    Thanks, this fixes my bluetooth problem on Ubuntu 19.04
    – thanhdx
    May 10, 2020 at 2:55
  • 2
    I had exactly the same issue on 20.04.. Your solution worked!! Thanks! May 21, 2020 at 19:00
  • 1
    This solution helped me. Also this comment in Launchpad.net by TJ helped me identify exactly which hcd file I need to download from the github repo of winterheart: bugs.launchpad.net/ubuntu/+source/linux/+bug/1743336/comments/3 So I have submitted that info to add as an update in this answer.
    – rineez
    Aug 9, 2020 at 13:39
  • 2
    Although, this answer has redirected to specific file BCM HCD file, please visit the GIT repository and get the exact HCD file shown in your terminal error. This method works on Ubuntu 20.10, confirmed.
    – Aditya T
    Dec 19, 2020 at 8:25
  • 1
    I tried about a hundred different things and this finally got Bluetooth working on my Ubuntu mate 20.04. Thank you! Jun 6, 2021 at 10:02

These commands may help you:

  1. Install bluez:

    sudo apt-get install bluetooth bluez bluez-tools rfkill
  2. rfkill check and unblock:

    sudo rfkill list
    sudo rfkill unblock bluetooth
  3. Start bluetooth service:

    sudo service bluetooth start
  4. Install bluetooth manager GUI:

    sudo apt-get install blueman

Reference: https://www.youtube.com/watch?v=z-K8IcS_nVw

  • I changed the firmware for my broadcom bluetooth, restarted and executed command to unblock the bluetooth. Then it worked. Aug 4, 2019 at 16:53
  • @JitendraKumar can you post a new answer explaining what you did clearly? Aug 5, 2019 at 14:21
  • can you please review? askubuntu.com/questions/1224993/…
    – Kar19
    Apr 7, 2020 at 12:36

I had this issue too. I tried the suggestions here but none worked for me. My fix was a simple one.

I restart the Bluetooth service using this

sudo service bluetooth restart

I could find and connect to new devices after.

  • 1
    This answer should be marked as the answer, and not the one where you have to shut off the computer!! This answer is perfect and is something that should be seen as the one. Jun 17, 2021 at 13:37

Whilst Hassan's suggestion did not fully solve my issue, it set me on the path that did solve it.

I don't have rep to post a comment yet, but just wanted to say thank you SO much to Hassan as part of your solution lead me to find a solution for this issue.

It was specifically installing Blueman that helped me solve my issue (whereby my BT headphones stopped connecting after months of working fine).

Whilst Blueman did not solve my issue, it did provide the error:

Connection Failed: blueman.bluez.errors.DBusFailedError: Protocol not available...

On Googling that error, I then did the following and the headphones now connect.

  1. I installed blueman:

    sudo apt-get install blueman
  2. Then I ran these commands:

    sudo apt-get install pulseaudio-module-bluetooth
    killall pulseaudio

Then, after restarting Ubuntu, I was able to connect via Blueman.


The answer posted by Hasan ibrahim didn't work for me. I have a Broadcom Bluetooth and Ubuntu 18.10 operating system. I found out that the firmware was incorrect. So, I download the suitable firmware for my Bluetooth as mentioned in https://askubuntu.com/a/632348/679670 and replaced my Bluetooth firmware with the suitable one. However, my Bluetooth was still not detecting Bluetooth devices.

Then I executed below command from Hassan ibrahim's answer

sudo rfkill unblock bluetooth

and restarted my system.

After which my Bluetooth detected other Bluetooth devices.


Answer posted by Yadnesh Salvi pointed me in the right direction to my issue on Ubuntu 18.04.

In my case, i was missing BCM43142A0-0a5c-21d7.hcd and on restart after copying, i found that i am also missing BCM43142A0-105b-e065.hcd.

Followed the same steps as suggested for the missing BCM43142A0-105b-e065.hcd as well and it worked like charm.


I had same problem but it is now solved just download the file and run the command to move this firmware driver for bluetooth. after moving driver file just make a restart your linux pc. https://github.com/winterheart/broadcom-bt-firmware/blob/master/brcm/BCM43142A0-0a5c-21d7.hcd

command :sudo mv downloads/BCM43142A0-0a5c-21d7.hcd/ /lib/firmware/brcm/BCM43142A0-0a5c-21d7.hcd

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .