My new 1,5 TB ext4 Hard Disk makes mysterious noises and fails to read and write. But not always. Sometimes it just works. But then I get those following errors. Does anyone know a solution for that or is my new WD Caviar Black 1.5 TB hard disk broken?

[  551.162286] ata7: SATA link down (SStatus 0 SControl 310)
[  551.162294] ata7.00: link offline, clearing class 1 to NONE
[  551.178223] ata7: EH complete
[  551.190802] ata7: exception Emask 0x10 SAct 0x0 SErr 0x4040000 action 0xe frozen
[  551.190807] ata7: irq_stat 0x00000040, connection status changed
[  551.190811] ata7: SError: { CommWake DevExch }
[  551.190818] ata7: limiting SATA link speed to 1.5 Gbps
[  551.190822] ata7: hard resetting link

Update Mainboard P7P55D LE: http://www.asus.de/Motherboards/Intel_Socket_1156/P7P55D_LE/#specifications

  • Can you add info about your motherboard? – gajdipajti Apr 27 '12 at 7:31
  • I have the same error. I disconnected all sata devices and the error is still there. When the bios is starting I have an error briefly displayed about a JMicron NVRam disk that can't be mounted. The motherboard has 6 sata connectors. By disconnecting I mean completely removing the cords. – chmike Aug 21 '13 at 20:19
  • Do you have any other SATA controller? And do you have the exact same errors? – thonixx Aug 22 '13 at 7:19

That SATA error is not good, but can only really be diagnosed by trying the following:

  • pop this disk in another box
  • put another disk in this box

That will narrow it down. If the disk still fails in the other box, try and get the data off it if it gives you some uptime, then ditch it

If the other disk fails in your computer, it is the SATA card, replace it (or if SATA is on the motherboard - you'll need to look at replacing the motherboard)

| improve this answer | |
  • Now I have another failure with a new hard disk: [ 1043.423048] sd 6:0:0:0: [sdc] Unhandled error code [ 1043.423049] sd 6:0:0:0: [sdc] Result: hostbyte=DID_BAD_TARGET driverbyte=DRIVER_OK [ 1043.423051] sd 6:0:0:0: [sdc] CDB: Read(10): 28 00 00 00 00 00 00 00 08 00 [ 1043.423055] end_request: I/O error, dev sdc, sector 0 – thonixx Apr 23 '12 at 21:09

Buy a new one, its broken. Now I hope everything works fine. Update the second one worked for 6 days and now it is broken again. I will exchange it for a new model and hope for a little bit luck.

| improve this answer | |
  • You need to limit to sata 1 with a jumper on the hdd. – gajdipajti Apr 26 '12 at 20:33
  • This would be a solution to backup data? – thonixx Apr 26 '12 at 21:52
  • No, it would be a solution to keep your hdd alive – gajdipajti Apr 27 '12 at 7:32
  • Could it be that I never had this problem before until 6 days of usage (only just a few hours per day in those 6 days)? – thonixx Apr 29 '12 at 20:49
  • I had problems with a sis sata chip on my motherboard. It was my secondary hdd, so I only used it for data. If I copied around 100 MB everything was ok, but at 1 GB and above it simply failed. I had to limit the bandwidth, and after it worked ok. – gajdipajti Apr 29 '12 at 20:59

Cause: SATA II hard drives use autospeed negotiation. This enables our SATA II drives to automatically detect the motherboard data transfer rate, making it backward compatible with SATA I data transfer rates. However, some older SATA I controllers are unable to support autospeed negotiation and cannot recognize the drive. This “drive not detected” condition occurs when a chipset is incapable of correctly negotiating the data transfer speed with a SATA II hard drive.

To lock the drive at 150 MB/s data transfer rate install a jumper shunt on pins 5-6 (OPT1), shown in the picture below. (Only available on 3.5 inch (Desktop) size drives) enter image description here

From: http://wdc.custhelp.com/app/answers/detail/search/1/a_id/1337/c/130/p/227,279

| improve this answer | |
  • Even the hard disk is SATA 3 and my mainboard supports SATA 3? (Mainboard P7P55D LE: techspec) And hard disk is detected but results in errors (see the comment under rory alsop) – thonixx Apr 29 '12 at 21:08
  • As your motherboard supports sata 3, your problem lies elsewhere. – gajdipajti Apr 29 '12 at 21:24

I hope this helps someone out - this immediately solved my problem.

If you are using a desktop computer, open it up and disconnect your DVD/CD drive. After doing this it booted up without incident. Just to make sure, I also booted into compatible mode from the GUI settings.

I wanted to clarify. I had read multiple forums over the net. With the 'compatibility mode' from the GUI setting and adding additional parameters, nothing appeared to be working after getting the ata7: hard resetting link. Now that I have finally loaded Linux Mint Cinnamon for the first time, I am installing it and will update this thereafter.

| improve this answer | |
  • So, how'd it go? – Victor Mar 15 '17 at 1:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.