0

Dual booting Windows 10 and Ubuntu 18.10.

Used UUI and Rufus, but neither worked. Is there any possible way to fix that? I can't find any answer to this question on the web.

Booting 'Boot ubuntu'

(hd0,0)  
Filesystem type is iso9660_Joliet, using whole disk
  [Linux-bzImage, setup=0x4200, size=0x821b58] 
initrd /casper/ILUG

Error 15:(http://grub4dos.chenall.net/e/15)  
         File not found

Press any key to continue...

enter image description here

4
2

When you use Ubuntu Installer to make a boot by USB, you have to choose format type of USB is FAT32. That's it.

1
  • Thanks. I used Universal USB Installer. It somehow used NTFS. Then I used Rufus. It installed using FAT32 and worked. I was trying to run Linux Mint from USB with persitence. – Joy George Kunjikkuru Sep 9 '20 at 18:37
0

I ran into a similar problem using YUMI-2.0.5.9 via wine-staging in Ubuntu 18.04.1. Hard to believe but some versions of YUMI do work in that configuration when the target (FAT32) USB stick is mounted prior to running it.

YUMI, however, works differently depending on circumstance. In Win 10 it extracted my xubuntu-18.04.1-desktop-amd64.iso into folders. In Linux, it just copied the iso to USB with this directory structure.

 YUMI
 xubuntu-18.04.1-desktop-amd64.iso
 initrd
 vmlinuz
 ubuntu.lst

ubuntu.lst has these contents:

 title Boot xubuntu-18.04.1-desktop-amd64
 set ISO=/multiboot/xubuntu-18.04.1-desktop-amd64/xubuntu-18.04.1-desktop-amd64.iso
 set CASPER=/multiboot/xubuntu-18.04.1-desktop-amd64/casper-rw
 find --set-root %ISO%
 map %ISO% (0xff)
 #CLUG
 map --hook
 root (0xff)
 kernel /casper/vmlinuz file=/cdrom/preseed/xubuntu.seed noprompt boot=casper iso-scan/filename=%ISO% quiet --
 #initrd /casper/ILUG
 initrd /casper/initrd

Notice that I commented out initrd /casper/ILUG and replaced it with initrd /casper/initrd. That solved the error for me. Presumably, http://grub4dos.chenall.net/e/15 would describe error 15 as a missing initrd. As of this writing, the page is not found.

I have ubuntu and lubuntu 18.04.1 on the same USB but their folders contain initrd.lz and their ubuntu.lst files say initrd /casper/initrd.lz. For whatever reason, YUMI gets the correct, yet oddly named initrd, but doesn't pass the correct filename to the resultant menu.

Not a grub4dos problem at all.

0

For CDFS, make sure menu.lst case references are UPPERCASE

I got this error when attempting to boot from a USB drive that had been set bootable. During boot, I got the Error 15 message.

I had downloaded the Ubuntu ISO image, and the file name was in lowercase.

I used the Universal USB Installer tool to burn the image (caveat).

When I booted, I got the Error 15 message. With some research, it seems that the CDFS file system is case sensitive.

To remedy, I inserted the USB drive into my Windows PC, and navigated to the \boot\grub\menu.lst file, and edited it, changing all instances of:

UBUNTU-18.04.3-DESKTOP-AMD64      ➜  UBUNTU-18.04.3-DESKTOP-AMD64
UBUNTU-18.04.3-DESKTOP-AMD64.ISO  ➜  UBUNTU-18.04.3-DESKTOP-AMD64.ISO

I also updated the ISO image filename in the root directory on the USB drive to be uppercase:

\UBUNTU-18.04.3-DESKTOP-AMD64.ISO

After these changes were made, I rebooted via USB, and it worked.

0

I have simply updated YUMI to 2.0.6.9 and made the pendrive in FAT32 file system. This way, it already pointed to the correct initdr.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.