1

When I try to update using apt-get update give above error. I don't what causes this error, do you have any idea how can I fix this ?

W: GPG error: http://download.opensuse.org/repositories/home:/Horst3180/xUbuntu_16.04 Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 5A7D1D38BEB6D886 W:

The repository 'http://download.opensuse.org/repositories/home:/Horst3180/xUbuntu_16.04 Release' is not signed. N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use. N: See apt-secure(8) manpage for repository creation and user configuration details.

  • 1
    Are you using any package/service of OpenSUSE? – Kulfy Nov 10 '18 at 7:43
  • @Kulfy it seems so – Hasan Tıngır Nov 10 '18 at 7:50
2

It seems that you need to visit corresponding software.opensuse.org OpenSuSe site and then follow instructions from it for the Ubuntu:

You can add the repository key to apt. Keep in mind that the owner of the key may distribute updates, packages and repositories that your system will trust (more information). To add the key, run:

wget -nv https://download.opensuse.org/repositories/home:Horst3180/xUbuntu_16.04/Release.key -O Release.key
sudo apt-key add - < Release.key
sudo apt-get update

Also note that OpenSuse build service page for this repository is located on build.opensuse.org.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.