6

Ok, so it seems there is no longer a xorg.conf, so how do I get to set the coolbits option now? I tried creating a config file automatically through nvidia-settings, but X fails if I do so. I have a nvidia optimus card btw...

2
  • I am in the same boat. Please report back here should you find a solution.. I'll do the same.
    – MadHatter
    Mar 15, 2019 at 22:33
  • @MadHatter if you still looking for it, posted how I did it in my case, maybe it will help.
    – Esuil
    Mar 31, 2019 at 13:13

2 Answers 2

8

In Ubuntu MATE 18.04 possible solution is to edit config in /usr/share/X11/xorg.conf.d, namely file 10-nvidia.conf. Here is how it looks in my case for example:

Section "OutputClass"
    Identifier "nvidia"
    MatchDriver "nvidia-drm"
    Driver "nvidia"
    Option "AllowEmptyInitialConfiguration"
    Option "Coolbits" "12"
    ModulePath "/usr/lib/x86_64-linux-gnu/nvidia/xorg"
EndSection

I just installed nvidia-prime via Additional Drivers GUI and then edited this file to add Coolbits option and it worked with no issues.

I assume it should work the same for main branch of Ubuntu.

I edit my input options using file 40-libinput.conf in same directory as well.

2
  • Worked, thanks :) I set the Coolbits to "255" though.
    – Szpaqn
    Apr 20, 2021 at 20:53
  • @Szpaqn yeah, this post is ~2 years old, so some values are likely different due to system updates, different drivers etc.
    – Esuil
    Apr 21, 2021 at 12:50
2

That was a good answer, but I think things have become slightly easier.

Unless you have some kind of custom xorg configuration you can just run this command.

sudo nvidia-xconfig --cool-bits=8

Your cool-bits number will likely vary depending on your graphics card. GreenWithEnvy gave me mine although not sure if it is accurate so double check. It is an Nvidia graphics card monitoring and overclocking software. If you haven't heard of it. You can find it on FlatHub.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .