1

I've tried a number of different ways of tracking down what's using the space on my SSD drive. I apologize in advance as I don't totally understand Linux and filesystems.

I have three drives. The SSD is 120GB and intended to have the operating system and programs. Some is partitioned to swap, so of the 112GB on the main partition only has 20G available.

here is df -h output

$ df -h
Filesystem              Size  Used Avail Use% Mounted on
udev                    3.9G     0  3.9G   0% /dev
tmpfs                   788M   82M  706M  11% /run
/dev/sda1               103G   78G   20G  81% /
tmpfs                   3.9G   28M  3.9G   1% /dev/shm
tmpfs                   5.0M  4.0K  5.0M   1% /run/lock
tmpfs                   3.9G     0  3.9G   0% /sys/fs/cgroup
/dev/sdb1               3.6T  327G  3.1T  10% /media/Media
/dev/sdc1               3.7T  2.5T  1.2T  68% /media/Data
tmpfs                   788M   72K  788M   1% /run/user/1000
/dev/mapper/veracrypt7  2.0T  451G  1.5T  24% /media/veracrypt7

I can't begin to find what's using the 92GB. I tried several du commands mentioned in other posts, and the 2 largest directories are only 4GB (/usr) and 2GB (/var). Nothing else even comes close in size. I tried ncdu and it also did not find anything of substantial size on that drive.

My other 2 drives are 4TB each and house my media / backups / Plex / Nextcloud. That's all I use this system for.

Model: ATA KINGSTON SA400S3 (scsi) 
Disk /dev/sda: 120GB 
Sector size (logical/physical): 512B/512B 
Partition Table: msdos 

Disk Flags: 
Number    Start    End   Size     Type      File system   Flags 
  1      1049kB  112GB  112GB  primary             ext4    boot 
  2       112GB  120GB 8475MB extended 
  5       112GB  120GB 8475MB  logical   linux-swap(v1)

The Disk Usage Analyzer application gives me similar results - "/" is 7.9GB, /usr is 4.2GB, /var is 1.8GB, and it gets smaller from there. It just doesn't add up, which is frustrating. It does say error opening directory '/etc/ssl/private':Permission denied. As for hibernation, I have no idea. I've never enabled it. Is there a way to check? RAM is 8GB

If anyone can help me find what's using the mystery 86GB I would appreciate it. When answering please remember that I know next to nothing!

  System: Ubuntu 16.04
  Kingston 120GB SSD
  WD 4TB hard drive (Backup)
  WD 4TB hard drive (Media)

  • 2
    Just curious what the ps ux would help with. It seems a bit long to post. Are there things in particular you're looking for? – mkinsocal Nov 10 '18 at 4:12
  • 1
    1. Open the terminal and run sudo parted -l to show all the partitions that Ubuntu can see. Please comment about the results. 2. Open the built-in Disk Usage Analyzer by clicking on its icon in the Dash and click on the ext4 partition. Then wait a few minutes for Disk Usage Analyzer to make a pie chart showing what is taking up the remainder of the used space on the 506GB ext4 partition. 3. Is hibernation enabled? 4. How much RAM is in your computer? – karel Nov 10 '18 at 4:14
  • 2
    Possible duplicate of Check how space is distributed on a Linux system – N0rbert Nov 10 '18 at 7:42
  • 1
    Can you please post the output of df -h? Which tool is telling you that used space is 92 GB? – fra-san Nov 10 '18 at 8:47
  • 1
    When folks ask you to "post" something, they are asking for the complete output, not a summary. And they are asking for you to edit your question to include the formatted output, not buried in commnents. Sorry that wasn't clear to you. Both karel and fra-san have asked for (complete) output that would likely have answered the question many hours ago. – user535733 Nov 10 '18 at 10:51
0

OK. Mystery solved. Kind of. After futzing around, I decided to dismount my veracrypt volume (which is on one of the 4TB drives) and suddenly a 75 GB file showed up on the SSD drive. I have no idea why this does not show up when the veracrypt partition is mounted, nor do I know why it's on this particular drive (there are other things that I have on veracrypt partition that are not on the SSD), but I suppose this is more a question for truecrypt. Anyway, all help was greatly appreciated.

  • Should you incur in this same issue again, remember that du is your friend. But bear in mind that you'll have to run it as root as in: sudo du -shx / (total used space on root file system only) or sudo du -achx --threshold=1GiB (show items bigger than 1GiB, including files (not just directories); show a grand total; adjust threshold to your needs). – fra-san Nov 11 '18 at 15:34
0

When I mount with truecrypt, there is a file /tmp/.truecrypt_aux_mnt1/volume whose size is my truecrypt encrypted file size.

  • Yeah, but my veracrypt file is 2TB so not sure where the 75 GB file is from. It’s a rogue backup from my windows machine. No clue why it’s on my system drive and why it becomes hidden when I mount veracrypt. It’s not in /tmp. Anyway, a discussion for elsewhere I suppose. – mkinsocal Nov 11 '18 at 7:55
  • I see in output of mount, truecrypt on /tmp/.truecrypt_aux_mnt1 type fuse.truecrypt (rw,nosuid,nodev,relatime,user_id=0,group_id=0,allow_other). It doesn't tell where that truecrypt comes from. Maybe we should ask truecrypt or veracrypt developers. – Bob Johnson Nov 11 '18 at 9:34

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.