0

Please, anybody, help me.

It's been about 2 months since I've installed ubuntu on my HP Envy laptop. First installed Ubuntu 16.04 and than updated to 18.04. The wifi randomly freezes although the applet shows that it is still connected. Reconnecting to wifi either by disabling wifi and enabling again or by trying to connect to some other session and than connection back brings internet back for a random time between 5 seconds and a couple of minutes.

Tried to find anything in /var/log/syslog with no success. Found in forums that should blacklist acer_wmi so I added a record in /etc/modprobe.d/blacklist.conf nothing changed. Tried adding options options iwlwifi 11n_disable=1, 2 or 8 - nothing changed.

ifconfig shows

wlan0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
    inet my.indet.add.ress  netmask 255.255.255.0  broadcast my.ip.add.ress
    inet6 fe80::5ee0:c5ff:fe40:7ed2  prefixlen 64  scopeid 0x20<link>
    ether mac_address  txqueuelen 1000  (Ethernet)
    RX packets 114873  bytes 164468194 (164.4 MB)
    RX errors 0  dropped 0  overruns 0  frame 0
    TX packets 35470  bytes 4605873 (4.6 MB)
    TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

The output of lshw -c network

  *-network                 
   description: Ethernet interface
   product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
   vendor: Realtek Semiconductor Co., Ltd.
   physical id: 0
   bus info: pci@0000:07:00.0
   logical name: eth0
   version: 15
   serial: 30:8d:99:1d:dd:04
   size: 10Mbit/s
   capacity: 1Gbit/s
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress msix bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
   configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half firmware=rtl8168h-2_0.0.2 02/26/15 latency=0 link=no multicast=yes port=MII speed=10Mbit/s
   resources: irq:49 ioport:4000(size=256) memory:c6104000-c6104fff memory:c6100000-c6103fff
*-network
   description: Wireless interface
   product: Wireless 7265
   vendor: Intel Corporation
   physical id: 0
   bus info: pci@0000:08:00.0
   logical name: wlan0
   version: 61
   serial: 5c:e0:c5:40:7e:d2
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
   configuration: broadcast=yes driver=iwlwifi driverversion=4.16.0-041600-generic firmware=29.1044073957.0 ip=192.168.2.152 latency=0 link=yes multicast=yes wireless=IEEE 802.11
   resources: irq:53 memory:c6000000-c6001fff

the output of iw wlan0 info

Interface wlan0
ifindex 4
wdev 0x1
addr my_mac
ssid MYSSID
type managed
wiphy 0
channel 9 (2452 MHz), width: 20 MHz, center1: 2452 MHz
txpower 22.00 dBm

The result of nmcli dev wifi list

IN-USE  SSID       MODE   CHAN  RATE        SIGNAL  BARS  SECURITY 
*       MY_SES_ID  Infra  9     130 Mbit/s  72      ▂▄▆_  WPA2 

The output of dmesg | grep -e wlp -e iwl

[   17.717549] iwlwifi 0000:08:00.0: loaded firmware version 29.1044073957.0 op_mode iwlmvm
[   18.840384] iwlwifi 0000:08:00.0: Detected Intel(R) Dual Band Wireless AC 7265, REV=0x210
[   18.860756] iwlwifi 0000:08:00.0: base HW address: 5c:e0:c5:40:7e:d2
[   19.308984] ieee80211 phy0: Selected rate control algorithm 'iwl-mvm-rs'
[  316.393910] iwlwifi 0000:08:00.0: loaded firmware version 29.1044073957.0 op_mode iwlmvm
[  316.399446] iwlwifi 0000:08:00.0: Detected Intel(R) Dual Band Wireless AC 7265, REV=0x210
[  316.422826] iwlwifi 0000:08:00.0: base HW address: 5c:e0:c5:40:7e:d2
[  316.485142] ieee80211 phy0: Selected rate control algorithm 'iwl-mvm-rs'
[ 2497.073466] iwlwifi 0000:08:00.0: Detected Intel(R) Dual Band Wireless AC 7265, REV=0x210
[ 2497.098289] iwlwifi 0000:08:00.0: base HW address: 5c:e0:c5:40:7e:d2
[ 2497.160163] ieee80211 phy1: Selected rate control algorithm 'iwl-mvm-rs'

Everything indicates that I have no problem, though I cannot use ubuntu on my laptop.

The only suspicious thing I noticed (and I do not know if this is even related to the problem) is the result of iw reg get

global
country 00: DFS-UNSET
(2402 - 2472 @ 40), (6, 20), (N/A)
(2457 - 2482 @ 20), (6, 20), (N/A), AUTO-BW, PASSIVE-SCAN
(2474 - 2494 @ 20), (6, 20), (N/A), NO-OFDM, PASSIVE-SCAN
(5170 - 5250 @ 80), (6, 20), (N/A), AUTO-BW, PASSIVE-SCAN
(5250 - 5330 @ 80), (6, 20), (0 ms), DFS, AUTO-BW, PASSIVE-SCAN
(5490 - 5730 @ 160), (6, 20), (0 ms), DFS, PASSIVE-SCAN
(5735 - 5835 @ 80), (6, 20), (N/A), PASSIVE-SCAN
(57240 - 63720 @ 2160), (N/A, 0), (N/A)

phy#0 (self-managed)
country 00: DFS-UNSET
(2402 - 2437 @ 40), (6, 22), (N/A), AUTO-BW, NO-HT40MINUS, NO-80MHZ, NO-160MHZ
(2422 - 2462 @ 40), (6, 22), (N/A), AUTO-BW, NO-80MHZ, NO-160MHZ
(2447 - 2472 @ 40), (6, 22), (N/A), AUTO-BW, NO-HT40PLUS, NO-80MHZ, NO-160MHZ
(2457 - 2482 @ 40), (6, 22), (N/A), AUTO-BW, IR-CONCURRENT, NO-HT40PLUS, NO-80MHZ, NO-160MHZ, PASSIVE-SCAN
(5170 - 5190 @ 80), (6, 22), (N/A), NO-OUTDOOR, AUTO-BW, IR-CONCURRENT, NO-HT40MINUS, NO-160MHZ, PASSIVE-SCAN
(5190 - 5210 @ 80), (6, 22), (N/A), NO-OUTDOOR, AUTO-BW, IR-CONCURRENT, NO-HT40PLUS, NO-160MHZ, PASSIVE-SCAN
(5210 - 5230 @ 80), (6, 22), (N/A), NO-OUTDOOR, AUTO-BW, IR-CONCURRENT, NO-HT40MINUS, NO-160MHZ, PASSIVE-SCAN
(5230 - 5250 @ 80), (6, 22), (N/A), NO-OUTDOOR, AUTO-BW, IR-CONCURRENT, NO-HT40PLUS, NO-160MHZ, PASSIVE-SCAN
(5250 - 5270 @ 80), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40MINUS, NO-160MHZ, PASSIVE-SCAN
(5270 - 5290 @ 80), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40PLUS, NO-160MHZ, PASSIVE-SCAN
(5290 - 5310 @ 80), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40MINUS, NO-160MHZ, PASSIVE-SCAN
(5310 - 5330 @ 80), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40PLUS, NO-160MHZ, PASSIVE-SCAN
(5490 - 5510 @ 80), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40MINUS, NO-160MHZ, PASSIVE-SCAN
(5510 - 5530 @ 80), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40PLUS, NO-160MHZ, PASSIVE-SCAN
(5530 - 5550 @ 80), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40MINUS, NO-160MHZ, PASSIVE-SCAN
(5550 - 5570 @ 80), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40PLUS, NO-160MHZ, PASSIVE-SCAN
(5570 - 5590 @ 80), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40MINUS, NO-160MHZ, PASSIVE-SCAN
(5590 - 5610 @ 80), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40PLUS, NO-160MHZ, PASSIVE-SCAN
(5610 - 5630 @ 80), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40MINUS, NO-160MHZ, PASSIVE-SCAN
(5630 - 5650 @ 80), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40PLUS, NO-160MHZ, PASSIVE-SCAN
(5650 - 5670 @ 80), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40MINUS, NO-160MHZ, PASSIVE-SCAN
(5670 - 5690 @ 80), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40PLUS, NO-160MHZ, PASSIVE-SCAN
(5690 - 5710 @ 80), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40MINUS, NO-160MHZ, PASSIVE-SCAN
(5710 - 5730 @ 80), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40PLUS, NO-160MHZ, PASSIVE-SCAN
(5735 - 5755 @ 80), (6, 22), (N/A), AUTO-BW, IR-CONCURRENT, NO-HT40MINUS, NO-160MHZ, PASSIVE-SCAN
(5755 - 5775 @ 80), (6, 22), (N/A), AUTO-BW, IR-CONCURRENT, NO-HT40PLUS, NO-160MHZ, PASSIVE-SCAN
(5775 - 5795 @ 80), (6, 22), (N/A), AUTO-BW, IR-CONCURRENT, NO-HT40MINUS, NO-160MHZ, PASSIVE-SCAN
(5795 - 5815 @ 80), (6, 22), (N/A), AUTO-BW, IR-CONCURRENT, NO-HT40PLUS, NO-160MHZ, PASSIVE-SCAN
(5815 - 5835 @ 20), (6, 22), (N/A), AUTO-BW, IR-CONCURRENT, NO-HT40MINUS, NO-HT40PLUS, NO-80MHZ, NO-160MHZ, PASSIVE-SCAN

and iw reg set US/AM/GB/UK has no effect.

Please, anybody, help me to at least diagnose the problem. What logs should I look into? Should (how?) I enable some debugging info to trace the problem?

  • Please edit your question to add the result of: nmcli dev wifi list I notice your router is set at channel 9. Is this a specific choice or a result of auto channel select? Welcome to Ask Ubuntu. – chili555 Nov 8 '18 at 21:03
  • Done. I do not have control on my router. The ISP configures it. – Vahagn Nov 8 '18 at 22:54
  • Are there any clues here? dmesg | grep -e wlp -e iwl – chili555 Nov 9 '18 at 1:06
  • Updated the initial message – Vahagn Nov 9 '18 at 7:28
  • Is this a WiFi adapter or an internal – user610658 Nov 9 '18 at 8:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.