I just installed Ubuntu 18.04 on my Thinkpad 11e recently and have been learning what I can do with the command line.

I just learned about tlp and installed it to manage my battery life. I also learned that setting charging thresholds and calibrating the battery is possible on some Thinkpads using tlp, so I installed tp-smapi-dkms and acpi-call-dkms with the hope of learning to use these functions.

When installing tp-smapi I was prompted to create a user-key for the program, so I learned about secure-boot mode and decided to disable it. I uninstalled tp-smapi-dkms and acpi-call-dkms, disabled secure-boot using

mokutil --disable-validation

and rebooting to switch off secure-boot mode.

Now just before booting the screen displays 'booting in insecure mode' or something like that, so it seems that worked, but when I reinstalled tp-smapi-dkms I was still prompted to make a user-key (acpi-call-dkms didn't do this for me either time), so I went ahead and did that anyway. Now after all that, neither of these packages are enabled, and I have also since started to doubt that my hardware supports either of these packages.

  1. Does anyone know if a Thinkpad 11e can run these, or am I wasting my time?
  2. If it is possible, why are they still not enabled?
  3. Also can anyone make sense of why I was prompted to make a user-key even after disabling secure-boot?

This is my output for tlp-stat -b:

$ tlp-stat -b
--- TLP 1.1 --------------------------------------------
+++ ThinkPad Battery Features
tp-smapi   = inactive (kernel module 'tp_smapi' load error)
tpacpi-bat = inactive (unsupported hardware)
+++ Battery Status
/sys/class/power_supply/BAT1/manufacturer                   = LGC
/sys/class/power_supply/BAT1/model_name                     = 45N1749
/sys/class/power_supply/BAT1/cycle_count                    = (not supported)
/sys/class/power_supply/BAT1/energy_full_design             =  34040 [mWh]
/sys/class/power_supply/BAT1/energy_full                    =  31610 [mWh]
/sys/class/power_supply/BAT1/energy_now                     =  31610 [mWh]
/sys/class/power_supply/BAT1/power_now                      =      0 [mW]
/sys/class/power_supply/BAT1/status                         = Full
Charge                                                      =  100.0 [%]
Capacity                                                    =   92.9 [%]

And here is output for tlp-stat -s:

--- TLP 1.1 --------------------------------------------

+++ System Info
System         = LENOVO ThinkPad 11e 20D9CTO1WW
BIOS           = N15ET56W (1.16)
Release        = Ubuntu 18.04.1 LTS
Kernel         = 4.15.0-38-generic #41-Ubuntu SMP Wed Oct 10 10:59:38 UTC 2018 x86_64
/proc/cmdline  = BOOT_IMAGE=/boot/vmlinuz-4.15.0-38-generic root=UUID=0cc64dbb-570c-4aeb-8fb2-6250fb67feab ro quiet splash vt.handoff=1
Init system    = systemd v237
Boot mode      = UEFI

+++ TLP Status
State          = enabled
Last run       = 10:21:03 AM,   2546 sec(s) ago
Mode           = AC
Power source   = AC
  • ThinkPad 11e is not in TLP's whitelist for tpacpi-bat. Please add the output of tlp-stat -s to your post. – linrunner Nov 9 at 19:08
  • Change the beginning of line 44 in /usr/share/tlp/tlp-functions to readonly RE_TPACPI_ONLY='^(11e|13.*| and show tlp-stat -b again. – linrunner Nov 14 at 20:51
  • Hi @linrunner, thanks for your help with this. I'm wondering if you made an error in your suggested line edit since it ends with a pipe. I tried the edit anyway and got some errors from tlp-stat -b. I can send error messages if you that will help any, but was having trouble getting it to format correctly in this comment. Tried ctrl+k, four spaces and beginning of line, and '>' at beginning of line and none of these changed the formatting so I'm not sure what I'm doing wrong. It made the comment look confusing, but I have the info saved if needed. – keilyx 21 hours ago

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.