6

I'm using opera browser version 56.0.3051.43 on Ubuntu 16.04 with I3wm and I get

your browser does not currently recognize any of the video formats available

when trying to play some videos on youtube on respect to HTML5. I've seen a couple forums about this, but only about very outdated versions and none are very clear steps. How can I fix this problem?

  • What does the html5 page of youtube say? youtube.com/html5 Maybe Opera just doesn't support many formats... period. – Xen2050 Nov 8 '18 at 17:52
  • @Xen2050 it says opera supports HTML5 videos. – Gabriel Ziegler Nov 8 '18 at 17:58
  • There's six different "checkbox" formats on the page for me, plus a 7th for "The HTML5 player is currently used when possible." Do you only see one "checkbox," and which one? – Xen2050 Nov 8 '18 at 19:06
  • I have a ! mark in H.246 and in MSE & H.264, but the HTML checkbox is alright. – Gabriel Ziegler Nov 9 '18 at 10:23
  • For me Chromium has checkmarks in those two H.264 ones, but red !'s for the right two with WebM, Youtube has never complained... Are opera and all the video-related packages updated? There might be an extension/add-on to try asking for different video formats, chromium has some to request H.264, and block 60FPS videos (otherwise it's forced for higher res sometimes, terrible!) but I'm not sure about Opera. Web search found some ideas, I'd might as well post an answer – Xen2050 Nov 9 '18 at 15:52
9

Due to legal restrictions Opera is unable to distribute H264 codec. You can use the following workaround:

Install chromium-codecs-ffmpeg-extra package and create a link to libffmpeg.so:

sudo ln -sf /usr/lib/chromium-browser/libffmpeg.so /usr/lib/x86_64-linux-gnu/opera/libffmpeg.so

You can check your opera installation directory in the About dialog.

  • This worked for me with Opera 60 – Rutrus Jun 11 at 8:42
3

I had installed opera with the deb package downloadable from Opera's site and it did not load HTML 5 videos from youtube. The only solution that worked for me was to uninstall the version I had with:

sudo apt-get remove --purge opera-stable

and then installed the version from the PPA package following this other AskUbuntu post.

Adding a pointer to the opera stable sources:

sudo sh -c 'echo "deb http://deb.opera.com/opera/ stable non-free" >> /etc/apt/sources.list.d/opera.list'

Install the key:

sudo sh -c 'wget -O - http://deb.opera.com/archive.key | apt-key add -'

Fetch the new repository:

sudo apt-get update

Install latest Opera with:

sudo apt-get install opera-stable

Now Opera is able to handle HTML5 videos.

1

From a web search for opera linux enable h.264 I found this answer over on the Unix & Linux SE H.264 support for Opera and openSUSE that suggests trying a few different ideas, but it lead to a more promising looking Opera forum from 4 months ago that might/should work:

burnout426 4 months ago
@drpostman A little bit better directions.

Start Opera, goto, https://github.com/iteufel/nwjs-ffmpeg-prebuilt/releases/ and download the 0.31.4-linux-x64.zip file. In Opera's download dialog, click the folder icon to show the file in the file manager. Right-click it and choose "Extract here". This will give you libffmpeg.so.

Right-click in a blank spot in the file manager and choose "open as root" and type in your password. Then, right-click on libffmpeg.so and choose cut.

Then, in the file manager, browser to "/usr/lib/x86_64-linux-gnu/opera/". Right-click in a blank spot and choose to create a new folder named lib_extra. Once the folder is created, go into it, right-click on a blank spot and choose paste. You should then see libffmpeg.so there. Then, restart Opera and goto https://youtube.com/html5 to see if h.264 support is enabled for example. Then, test out some videos. On youtube, you can right-click on a video and choose "stats for nerds" to see if it's using vp9 or h.264. Or, you can try these h.264 videos to make sure they work.

You can then close the file manager.

(Tested on Linux Mint 19 Cinnamon x64)

Others answers that might be worth trying (from the earlier question) include:

  • Unfortunately, I followed the steps above and it did not work, but I got the solution now, I'll post the answer to my case. – Gabriel Ziegler Nov 10 '18 at 21:16
  • 2
    This didn't worked for me, but Sergey answer does (sudo ln -sf ...) – Rutrus Jun 11 at 8:43
0

My FIX: I went to https://www.youtube.com/html5 (Thx Grandpa Dave!),

  • Scrolled to the BOTTOM YOUTUBE LOGO on left
  • and just to the RIGHT of the bottom-left logo "LANGUAGE" and
  • CORRECTED my location/LANGUAGE.

Everything played fine after that. Pls share if this worked for you. It's a weird auto-location selection. I thought there might be a prob when the comp auto-filled my date/time with another country time, sure enough, youtube matched the incorrect auto location.

0

The problem is not so much with Opera and in all fairness the issue here is with libffmpeg.so which is in fact proprietary codec support. I have a little script that adds the support you need after an Opera update or install. Get the script here. Once you have it, make it executable and run it as follows.

chmod 755 opera_codec.sh
./opera_codec.sh

Hope this helps you out as it has always worked for me. You can then go test your html5 support at https://html5test.com

0

If anyone is looking for a one-line Opera install script you can use the following:

curl -sSL https://raw.githubusercontent.com/icolwell/install_scripts/master/opera_install.bash | bash

I've updated the install script according to Sergey Podobry's answer so it will link the correct video codecs. The script is hosted here.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.