I am running ubuntu 18.04 and just sintalled a VNCserver on Gnome.

To do it, as it was the first time I tried it, I read an online guide.

The result is I have the VNC server installed and I can connect to it, but when I do it from my Android tablet it only appears a grey screen.

This is the content of my config file:


xrdb $HOME/.Xresources
xsetroot -solid grey
#x-terminal-emulator -geometry 80x24+10+10 -ls -title "$VNCDESKTOP     Desktop" &
#x-window-manager &
# Fix to make GNOME work

And this are the errors of the Xtightvnc log:

Font directory '/usr/share/fonts/X11/75dpi/' not found - ignoring
Font directory '/usr/share/fonts/X11/100dpi/' not found - ignoring
xrdb: No such file or directory
xrdb: can't open file '/home/ubuntu/.Xresources'

I achieved to fix the problems with the fonts, I only have to struggle with the xrdb, and I have no idea on how to fix it.

And just to clarify, when I installed the packets I install all of this, and maybe more "sudo apt-get install gnome-panel gnome-settings-daemon metacity nautilus gnome-terminal x11-xserver-utils"

Thanks in advance

  • 1
    Please post code as code. Either use the backtick or click { } . – GabrielaGarcia Nov 8 '18 at 15:52

It can happen if there is no monitor on a server. Make sure that your monitor is plugged in.

If not try these:

  1. ssh/putty into monitorless server
  2. enter "vnc4server :1"
  3. enter "export DISPLAY=:1"
  4. enter "x-session-manager &"
  5. exit terminal session and you should now be able to vnc into the server with "vncviewer server_name :1"

p.s. taken from ubuntu forums. (https://ubuntuforums.org/showthread.php?t=820693)

  • Welcome to askubuntu omykoms. I suggest you add a link to the Ubuntu forums page where you got the information from. – Juan Antonio Nov 8 '18 at 17:23
  • For sure: ubuntuforums.org/showthread.php?t=820693 – omykoms Nov 8 '18 at 20:29
  • I edited the first post with more info and some improvements. What you purpose I can't do it because it seems the android version of putty it only works as a SSG client, and as my vncserver config is without SSH I can't connect to it. – Betsita Nov 9 '18 at 2:16

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.