Running Ubuntu LTS 18:04 with nvidia, was working fine.

Recently did an apt-get upgrade, and now am no longer able to log in to my desktop. Lightdm starts fine, with both monitors supported, but when I log in, after about a minute I get booted back to the login.

I use Gnome legacy.

Previously, all I had to do was reinstall the nvidia drivers, but this no longer works.

I have tried purging, and using both the distro nvidia drivers and .run.

The only errors I can see in the log are a bunch of:

Activated service 'org.freedesktop.systemd1' failed: Process org.freedestop.systemd1 exited with status 1

But I'm not sure what that means, if anything.

What recent changes could have broken this? Like i said, everything worked fine until I did an apt-get upgrade yesterday.

UPDATE

I have now tried a fresh reinstall with an empty home directory and it still fails with a dbus error.

It looks like there was a recent change introduced which breaks dbus/gnome-fallback/something.

Any thoughts? This is a bit of a showstopper

UPDATE

Ok, after a LOT of playing around, i've managed to isolate the problem. Basically, it seems that something changed in dbus/systemd/x or whatever, in the last few days, which means that you can NO LONGER log in with an NIS based user.

I fudged it, by creating a dummy copy entry of my users in /etc/passwd from the server. This lets me log in at least.

Obviously this is not a sustainable solution....

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.