2

I recently bought a Geobook 1m from PCWorld. It's a cheap computer but I thought running Linux it would be fine for me.

Unfortunately, the trackpad doesn't work properly. The physical buttons don't work, both right and left, the trackpad is erratic, oversensitive to movement at times and then not responsive at other times.

Also, the tap to click works when not clicked and doesn't work when you actually tap to click. I would really like to get this working and hope someone can help. Thanks

Here is my xinput -list

⎡ Virtual core pointer                     id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ HTIX5288:00 0911:5288 Touchpad            id=9    [slave  pointer  (2)]
⎜   ↳ p’s Mouse                                 id=13   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Video Bus                                 id=6    [slave  keyboard (3)]
    ↳ Power Button                              id=7    [slave  keyboard (3)]
    ↳ USB 2.0 Web Camera: USB 2.0 Web           id=8    [slave  keyboard (3)]
    ↳ Intel HID events                          id=10   [slave  keyboard (3)]
    ↳ Intel HID 5 button array                  id=11   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=12   [slave  keyboard (3)]

Thanks.

1
1

I bought a Geobook 1M recently. I wanted the cheapest small laptop I could find anywhere, to use for a few days while travelling light. I loaded Xubuntu 19.04 and came across the same problem. The solution was rather straightforward: Disable the "Tap Touchpad to Click" option in the touchpad settings. It appears the problem is that every single movement of the touchpad is being treated as a click.

I also changed my /etc/default/grub to

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux"

which seems to help stability in general (remember to update-grub afterwards).

Then there is the problem of all the warnings being generated in kern.log when I touch the trackpad. I added these lines in my /etc/rsyslog.d/50-default.conf to deal with it

:msg, contains, "i2c_hid_get_input: incomplete report" -/dev/null
& ~

Finally, to suppress these warnings from the console:

dmesg --console-level 3

With these settings done, this is actually a pretty good linux ultraportable. Wifi, sound, microphone, camera, SD card work well.

0

I bought a slightly different model: the Geo Flex 11.6 inch. It has the same type of touchpad. From Google searching, I learned the touchpad problem was due to a bug in the Linux kernel prior to version 4.18, so installing a recent version of Linux can help. I found that Ubuntu Mate 19.04 works great. The answer by Michael P contains useful advice: ensure that touching the touchpad is not treated as being a mouse click. In Ubuntu mate, you can do this with the following:

Menu -> Prefernces -> Mouse -> Touchpad -> untick "Enable mouse clicks with touchpad".

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.