0

I installed python3 and pyopencl on ubuntu 18.04, now I want to use spyder to execute my codes, but it gives me an error while doing that:

ImportError: /usr/local/cuda-10.0/targets/x86_64-linux/lib/libOpenCL.so.1: version `OPENCL_2.1' not found (required by /usr/lib/python3/dist-packages/pyopencl/_cffi.abi3.so)

I think this is a simple problem, but I can't solve it, since I have no experience with those programs.

Can anyone help me, please?

0

Sounds like you need to install the python opencl libraries . Try running

sudo apt-get install python3-pyopencl
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.